Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.


I'm running my own postfix mail-server at home with a setup similar to this one. I opted to deliver tagged spam via dovecot to the user's spam-mailbox, so that they can review tagged emails if they wish to; these spam-mailboxes get purged regularly and SA's bayes is trained on them.

The thing that's annoying though is that SA (or amavisd-new, I'm not even sure on that) additionally saves the tagged spam to /var/virusmails/spam-xxx.gz, which I don't want. I cannot find the correct option in the configuration to turn that behavior off.

Any pointers well appreciated.

share|improve this question

1 Answer 1

Probably you need to set $QUARANTINEDIR to empty in amavisd.conf

# Location to put infected mail into: (applies to 'local:' quarantine method)
#   empty for not quarantining, may be a file (Unix-style mailbox),
#   or a directory (no trailing slash)
#   (the default value is undef, meaning no quarantine)
#
$QUARANTINEDIR = '/var/virusmails';
share|improve this answer
    
Thanks, it's not exactly what I want (but that's probably to my sloppy question). Defining $QUARANTINEDIR to empty also stops viruses etc. to be quarantined. However, when looking for the documentation of this variable, I found that setting $spam_quarantine_method to undef does what I want. –  jhwist Dec 29 '09 at 13:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.