Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm a Windows dev helping out a friend who has a Mac server. He set this server up a few months back (But has never been used)

When navigating to Server Preferances and using the following credentials we get the following error message.

Server: 127.0.0.1 (or server.pmd.int), User: [AdminUserName], Password: [AdminPassword]

Error: Unable to set node credentials for /LDAPV3/127.0.0.1 with the record name server.local$.

Now I am aware of this thread: http://discussions.apple.com/thread.jspa?threadID=2163498&tstart=0 - I've done the reboot, and the keychain does not contain 2 values.

Can anyone advise on troubleshooting methods?

Edit: Ran the query: dig -x 192.168.0.200 or host 192.168.0.200

alt text

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

Try hostname.local or the FQDN. You really SHOULD be able to use the FQDN. If you can't, it means your DNS server isn't set up correctly. All Apple OS X Servers need DNS to be set up correctly on the DNS server side. This is critical to getting almost all of the services set up correctly.

Since the OS has already been installed, verify that DNS is working by doing:

sudo changeip -checkhostname

You should get:

Primary address     = 10.10.10.10

Current HostName    = xserve.example.com
DNS HostName        = xserve.example.com

The names match. There is nothing to change.

Of course, substituting the IP address and hostname for their actual values.

I'd also recommend checking out http://consultants.apple.com/

** Update **

Your DNS is not set up correctly*. This is mandatory to set up OS X Server. Your DNS server (or whoever provides DNS) has to have a DNS record of the fqdn pointing to your server. Once that is done, run changeip - 192.0.0.12 192.0.1.10 oldhost newhost. oldhost would be server.local and newhost would be whatever your FQDN is. This MUST be done before you can go any further.

Since the server seems like a fresh setup, I would suggest even trying a re-install which will give you the chance to set it up correctly during the installation process which is a bit easier than trying to go back in and doing it afterwards.

A bit of advice though, Apple markets OS X Server to be "simple" and that it will "just work". While that may be true, you still need to know the ins and outs of it for when something stops working and you're not sure what to do. If you don't, hire someone who does.

*.local is not a FQDN. It is used for Apple's Bonjour service, which is a different thing altogether. Important to know the difference.

share|improve this answer
    
Sounds stupid, but in laymens terms how do I get a window to type the command? –  LiamB Dec 9 '09 at 14:11
    
You're looking for the Terminal application in your Applications/Utilities folder. –  churnd Dec 9 '09 at 14:14
    
Updated main post –  LiamB Dec 9 '09 at 15:02
    
"Your DNS server (or whoever provides DNS) has to have a DNS record of the fqdn pointing to your server" - Can you delve a little deeper? –  LiamB Dec 9 '09 at 17:29
    
Your DNS server needs a DNS record pointing to the IP address of your server. –  churnd Dec 10 '09 at 4:21
add comment

In your case changeip is telling you that your DNS name is misconfigured. From the terminal do a dig -x 192.168.0.200 or host 192.168.0.200 to find out exactly what your DNS server thinks your server name is. If you do not have DNS on your network, server.local may indeed be the correct name, but check. Once you have the correct name, use the Sharing pane of System Preferences to confirm your server is named based on the DNS name. Run scutil --get HostName (NOTE, type H-o-s-t-N-a-m-e, not your host name) to verify the host name setting there. If that is wrong, run scutil --set HostName <yourhostname>. Re-run changeip -checkhostname which should give you no errors now. Reboot and re-test.

share|improve this answer
    
Attached image of this to the main post. –  LiamB Dec 9 '09 at 17:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.