Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is sort of a vague question, but its really been bugging me for a long time. I cannot seem to get a connection between two computers to go above 300 kbit/s in my LAN. This seems to be a magical limit, since it has been present with two different switches, one windows box, one ubuntu box, one debian NAS and others. I'm starting to suspect that the settings of ISP routers is to prioritize internet traffic and cap the LAN. I've tried to cable computers together without the switches (for instance ubuntu<->debian NAS 30 MB/s, windows<->ubuntu similar), so that's not the problem. I also get the same cap for both wired and wireless communication, so encryption does not seem to be the bottleneck. Futhermore, the internet connection is excellent (10 Mbit/s without a problem), so the routers can apparently handle the load. There is also no defect cable or mysterious connected device, since I've tried every possible and simple configuration but still cannot get past the mysterious limit.

The routers I've tried are a Davolink DV-2020 and a Netgear WGT 624.

My question is if anyone else has seen this type of behaviour and can give some advice. Thanks in advance.

UPDATE: The NAS says full duplex:

eth0: link up<5>, full duplex<5>, speed 100 Mbps<5>

eth0      Link encap:Ethernet  HWaddr 00:16:XX:XX:XX:XX
          inet addr:192.168.1.12  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:258 errors:0 dropped:0 overruns:0 frame:0
          TX packets:380 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:512
          RX bytes:23632 (23.0 KiB)  TX bytes:51782 (50.5 KiB)
          Interrupt:21
share|improve this question
    
What are the IP settings on the computers? What speed and duplex is negotiated when they plug into the switch/router? –  sparks Dec 9 '09 at 20:35
    
Routers can only "control" traffic that goes through them. The traffic on your LAN wouldn't and shouldn't normally go through the router. –  joeqwerty Dec 9 '09 at 20:40
    
joeqwerty: I have an ISP box which is a router and a switch. A residential gateway I think you call them? –  Alexander T Dec 9 '09 at 20:52
    
sparks: The residential gateway has a DHCP server running, and most clients use DHCP. I've also tried static config in my linux configs to no avail. I haven't checked the duplex explicitly, but since all computers can access the inet at high speeds I suspect that this is not the problem. Could the bridging over the LAN NIC:s be overloading the router somehow? –  Alexander T Dec 9 '09 at 20:56
1  
Plug the hosts into a plain vanilla switch an unplug the router and test it. If you get the same results, then that rules out the router(s) as the problem. –  joeqwerty Dec 9 '09 at 21:07
show 1 more comment

1 Answer

up vote 0 down vote accepted

Is everything hooked up to the router/gateway/edge device or do you have separate switches in-between the router/gateway/edge device and the internal network?

Here are few ideas for you to look into

  • Check to see if any of the devices involved show any errors on their network interfaces.
  • Check the MTU settings as most small consumer/soho routers barely have a cpu so they will get overwhelmed quite easily if they are having to fragment packets.
  • Traceroute to see what the data path looks like on the network to make sure it's not doing anything crazy.
  • Do a quick packet capture on your network to make sure there's not a client that is effectively causing a DOS with broadcast packets or the like. This may indicate that a machine is infected.
share|improve this answer
    
Its a super simple setup: the external port on the router is connected to the ISP line, and the switch ports to my computers. No intermediate devices. I think the traceroute idea is good, will try that. –  Alexander T Dec 9 '09 at 20:59
    
Oh and the MTU could be a problem, but I would expect not since inet works well... –  Alexander T Dec 9 '09 at 21:01
    
Added NAS box status in the question –  Alexander T Dec 9 '09 at 21:18
    
I will get a new switch and if that works I will be accepting this answer since it was a good listing of possible problems. –  Alexander T Dec 10 '09 at 8:36
    
Accepted, got a wndr3700 and everything is running perfectly. –  Alexander T Dec 20 '09 at 14:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.