Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have got a new job and the existing SBS 2003 domain setup is unsecure (i.e. everyone is a domain admin etc etc). There are lots of problem due to inexperienced "network admin", and I am trying to fix them one by one.

There exist one issue which I found quite weird, that the "Quota" tab exists in the C:(NTFS) drive but not the D:(NTFS) drive. I played around with gpedit to enable disk quota (it was "not configured" before), but still I can't see that tab.

Have you seen this problem before? How did you solve it?

alt text

share|improve this question
Let me provide more diagnostic info. In console, "fsutil quota query c:" has no problem displaying the quota settings. But for "fsutil quota query e:", an error prompt comes out saying "Error: Access is denied". – deddebme Jan 11 '10 at 19:37

Well I've never experienced this but the following snippet from seems to point to a cause and a solution:

When you right-click a volume and press Properties, the Quota tab is missing?

If your user account does NOT have the Bypass Traverse Checking user right, you will experience this behavior.

To resolve this behavior:

  1. Right-click the volume in My Computer and press Properties.

  2. Select the Security tab.

  3. Press the Advanced button.

  4. Select your account or group and press the View/Edit button.

  5. Select This folder, subfolders, and files in the Apply onto drop-down box.

  6. Check the Allow box for Traverse Folder / Execute File and press OK.

  7. Press Apply and OK until all the dialog boxes are closed.

share|improve this answer
The thing is "Traverse Folder" has been allowed by default...what else should I do? I don't think I should disable it, apply once, then re-enable it. – deddebme Dec 9 '09 at 21:59


And look under "Yes Microsoft Disk Quota UI Property Sheet " if it is enabled or not.

Or try:

Start > Run > Regsvr32 dskquoui.dll > Press OK.

share|improve this answer
I can see the "disk quota" in C: drive, so I think that property sheet is enabled. Anyway I ran "Regsvr32 dskquoui.dll", the problem still exists. – deddebme Dec 10 '09 at 13:19

Is it a drive with an older version of NTFS? Quotas were only added in Win 2000/NTFS 5

share|improve this answer
just to confuse matters version 5 is sometimes called version 3! – JamesRyan Jan 11 '10 at 15:32
both c: and e: are NTFS version 3.1 – deddebme Jan 11 '10 at 18:43

Is it a removable drive? if so, you have to enable quotas either from a policy, or via the registry

Check to see that both drives have the same version of NTFS? You can check this with the following command: fsutil fsinfo ntfsinfo C:

is it SBS 2003 R2? If so, have you tried using the File Server Resource Manager to manage quotas for the E drive?

share|improve this answer
It is not a removable drive. Both c: and e: are NTFS version 3.1. It is not R2, so FSRM is not available. – deddebme Jan 11 '10 at 18:43

If you have not already done it. Install Icacls from here.

then run

icacls e:\*.* /t /grant yourusername:(x)

this should give you the traveral rights, then logon off then log on again.

share|improve this answer
I don't think traveral right is the problem. Nevertheless I tried the icacls, the disk quota problem still exists. – deddebme Feb 22 '10 at 20:18

Have you verified the permissions on the root of the drive, not just the traversal rights? If the old admin did something dumb and removed the security rights to the root of the drive this can happen.

You can also remove the full control permission from the root of the drive only for your user account or group, then reapply which should reset everything for admin use. This is basically the same as setting traversal/execute but it will reapply those permissions.

share|improve this answer

Looks like you have tried a lot of stuff.

I would break out process monitor from sysinternals and then try to access the missing tab.

Look at the log file and save it then do the same for c drive and compare the bad to good.

Try to keep the log clear until you absolutely can't keep clearing it because it logs everything that going on.

share|improve this answer

The SBS Servers tend to gather a lot of backup data, in hidden directories that happens to get the quotas over the limit. You should check for such as at times the servers might have been set up to back up each of the clients in a small SBS environment. Once you do find these then you can proceed to un-hide and delete those files that you feel are no longer needed or not important to say the least. I had a similar scenario with a newer SBS Server and I just made a good back up of it and then merged it into a 2012 R2 Standard as it gives you more features than the depricated server you need to upgrade anyway. You may be able to use that server as a BDC once you move to a more current OS. You got to realize that is a 13 year old OS.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.