Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Any attempt to copy files larger than about 40 MB from a network share (a SAN running open filer / Samba) to my local machine running Windows 7 always results in the following error and the copy fails:

Error 0x800700DF: The file size exceeds the limit allowed and cannot be saved.

I've tried copying to my C: drive and a USB drive with the same results. Smaller files copy just fine. Clearly 40 MB is not that big of a file so I'm assuming it is some buggy interaction between windows 7 and Samba perhaps. Google has so far turned up nothing. Can anyone point me in the right direction?

share|improve this question

4 Answers 4

We recently upgraded OpenFiler/Samba on the file server and I can now happily report that I was able to copy a 3GB file with no problems.

share|improve this answer

I cannot find anything on that error either... Does this happen with any other computers in your network? Grasping at straws here, but I'd recommend capturing a network trace during the file copy operation with Netmon or WireShark and compare them with a trace of the operation working on another client, and see if any difference in the traffic jumps out at you.

share|improve this answer
    
I am able to copy large files from other linux/samba boxes on the network. I'll try wireshark if I don't make any headway. –  JJGroover Dec 11 '09 at 19:56

I was having this same problem and it seems to have disappeared -- maybe the most recent Win7 patch? Have you tested this in the last few days with a fully-updated system?

share|improve this answer

A similar error may be seen when WebDAV is used to download files from shares that look like samba but are not. It this case you may need to apply a registry fix to the HKLM\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\FileSizeLimitInBytes key and restart WebClient service.

See for example http://support.microsoft.com/kb/900900

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.