Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This usually happens a few minutes after restarting apache:

httpd daemons are up, but are not reading the requests from the sockets. The web clients just wait forever on the connection.

When I run netstat, the Recv-Qs are showing a positive byte count which does not change. So basically the connection between the client and apache is in the CONNECTED state but no progress is made.

Restarting apache solves the problem for a couple of minutes, but then it's deja vu all over again.

Other servers (sshd, ftpd, etc) are fine.

Where should I look further? Any clue? Thanks!

share|improve this question
    
Can you post your apache logs? –  Zypher Jan 10 '10 at 9:53
    
Try attaching to the process and see what it does with strace -p pid –  artifex Apr 13 '10 at 5:56
add comment

3 Answers 3

Run "netstat -l" to verify apache is on actively listening on port 80, then verify there isn't a firewall in the network path interfering with traffic, either on the localhost ("iptables -L") or on the network.

It also wouldn't be a bad idea to check the selinux logs if you have that enabled.

share|improve this answer
add comment

how many apache processes are running when this happen? If you are getting hammered which too many requests apache will seem to just hang.

share|improve this answer
add comment

Please post your httpd.conf as well as a your trasnfer log and error log which will help in diagnosing this. Are you setting a timeout in httpd.conf? http://www.faqs.org/docs/securing/chap29sec245.html

What type of file is being requested? Does this occur when hosting a static HTML file?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.