Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The clients in my domain could always connect to MSN-Messenger. This week, al of a sudden connection fails with error code 80072ee7. Troubleshooting learns that there is a problem with the "Keyports". All other internet activity is working. The server is set up with two LAN-adapters: one is connected to the internet, the other connects to the clients. If I bypass the server, the clients can again connect to msn messenger, but I do not want to reconfigure my network to that effect. So the server is blocking the msn messenger communication without any (conscious) intervention from me, the self professed system manager. The server runs Windows server 2003 Sp2. How can I troubleshoot this? Thanks!

share|improve this question

According to this troubleshooting post, error 80072ee7 is a problem with a firewall blocking MSN Messenger traffic. Their recommendations all center around firewalls on your client (Norton, McAfee, etc), but if you take a look at KB 927847 Network ports and URLs that are used by Windows Live Messenger, it lists all the ports/URLs used by MSN messenger. Make sure none of them are being blocked by your server.

share|improve this answer
up vote 1 down vote accepted

It proved to be a DNS issue after all. Normally the clients are configured to request their DNS settings from the server. The server only supplies its own IP address for this. After manually setting the primary DNS to the server and the secondary DNS to an outside DNS server everything works as it should. But: How can I configure the server to supply the outside DNS to the clients? How can the problem have originated? It can only have happened after an automatic reboot after an update as I have not reconfigured the server in months.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.