Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a few Macs that I want to join up to a Windows domain, when I join the test machine to the domain it works fine but when I reboot the computer it looses it's connection and I have to delete it and re-create it.

My Mac is called "macbook1" the domain is "lancaster.local" the Mac is running Mac OS X 10.6.1

I have performed the process described in http://support.apple.com/kb/HT3789?viewlocale=en%5FUS and the problem still persists

share|improve this question

migrated from superuser.com Dec 11 '09 at 12:55

This question came from our site for computer enthusiasts and power users.

2 Answers 2

up vote 1 down vote accepted

Have you disabled Bonjour on the Mac? Bonjour/Zeroconf uses the *.local domain which causes issues with domains that actually use .local.

The program that is in charge of Bonjour, mDNSResponder now also handles DNS for your Mac as well so disabling it like you could in 10.4 or 10.5 will result in issues with anything related to DNS for any GUI applications. Apple has posted a kbase article (http://support.apple.com/kb/HT3789?viewlocale=en%5FUS) in order to do this. I'm not in an AD environment so I don't have any first hand experience with AD and Snow Leopard.

share|improve this answer
    
No, how do i do that? –  Arcath Dec 9 '09 at 17:15

The problem appears to have been that the mac couldnt resolve dc.domain.tld properly. I added the line:

IP dc.domain.tld dc

to /etc/hosts and it works fine now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.