Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

It started happening today... all of a sudden, no apparent reason!

Here's the output from df:

assp:~# df -k
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/simfs             6291456   1378384   4913072  22% /
tmpfs                  8202680         0   8202680   0% /lib/init/rw
tmpfs                  8202680         0   8202680   0% /dev/shm

assp:~# df -i
Filesystem            Inodes   IUsed   IFree IUse% Mounted on
/dev/simfs           55781934   83005 55698929    1% /
tmpfs                2050670       2 2050668    1% /lib/init/rw
tmpfs                2050670       1 2050669    1% /dev/shm

assp:~# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/simfs            6.0G  1.4G  4.7G  22% /
tmpfs                 7.9G     0  7.9G   0% /lib/init/rw
tmpfs                 7.9G     0  7.9G   0% /dev/shm

Here's an actual entry from /var/log/mail.warn:

Dec 11 17:55:37 assp postfix/smtpd[30614]: warning: not enough free space in mail queue: 0 bytes < 1.5*message size limit
Dec 11 17:55:37 assp postfix/cleanup[30617]: warning: 4361D850D54: write queue file: No space left on device

.

share|improve this question
    
Please paste the output of df here? –  Matt Simmons Dec 12 '09 at 13:35
    
How about the actual log lines, plus anything around them that could be related? –  Bill Weiss Dec 13 '09 at 15:35
    
Are there any large files which are held open by running or Zombie processes? lsof might be of some help here –  Tom O'Connor Dec 15 '09 at 13:53
    
How about the output of postconf -n ? Also, maybe, du -sh / ? –  Bill Weiss Dec 15 '09 at 17:34
add comment

7 Answers

You might want to run a df-i to see if you have used up all your inodes.

You can have available storage space, and not have the ability to add files.

cache:~# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda1             132G   68G   58G  55% /
cache:~# df -i
Filesystem            Inodes   IUsed   IFree IUse% Mounted on
/dev/sda1            17514496 13543293 3971203   78% /

You also might want to check to see if you have any quotas set (repquota -va).

share|improve this answer
    
df -i shows only 1% of max inodes used. repquota -va shows no quotas in effect. –  Alex R Dec 12 '09 at 3:16
add comment

5% (iirc) of space is reserved for root, might be your filesystem is "full" for normal users. You can get more info with e.g.

tune2fs -l /dev/sda1

share|improve this answer
    
server has only 6.2GB total... 78% free. –  Alex R Dec 12 '09 at 3:15
    
This helped me out! Thanks. The entry to look at is Reserved block count and multiply it by Block size to get bytes reserved. –  Mei May 24 '11 at 14:53
add comment

Which device is full? Perhaps there's plenty of space on one partition, but another (e.g. /tmp) is full? Do a df -h and see if any of the partitions are close to full, and then figure out if postfix uses that partition.

share|improve this answer
    
None of the partitions actually are full... That's what so strange about the errors. –  Alex R Dec 13 '09 at 14:55
add comment

Just curious, but is your queue > 2GB in size? I'm wondering if it's running into a filesystem size limit or a hard limit for postfix. I know that Apache dies when it hits 2GB on the log file (or at least it did at one point)

share|improve this answer
    
What do you mean by that? "is your queue > 2GB in size" –  Alex R Dec 15 '09 at 13:38
    
I meant your mail queue. In case something went haywire and created a single file larger than 2GB, in which case maybe something died while trying to parse it. 2GB has been a historic limit for several programs, even when the filesystem itself supports larger files just fine. –  Matt Simmons Dec 15 '09 at 15:36
add comment

What is the value of message_size_limit which is set?

http://www.postfix.org/postconf.5.html#queue_minfree is a possible cause for this response.

share|improve this answer
    
I don't have message_size_limit, queue_minfree, or mailbox_size_limit. None of them are set in main.cf –  Alex R Dec 15 '09 at 13:42
add comment

From http://www.mail-archive.com/postfix-users@postfix.org/msg07849.html

Postfix tries to avoid the situation where the system is 100% full and it can no longer get work done.

To completely avoid such conditions, Postfix would have to reserve an amount of space the size of (message size limit * inbound concurrency). Unfortunately, this is not practical in many cases, so it settles for 1.5 times the message size limit.

This means that although you've got 5GB free - your settings are such that you need more.

share|improve this answer
add comment

I have same problem on OpenVZ virtual machine. Space is temporarily taken by backup.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.