Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here's the problem:

Provider has given to us a public IP address space x.y.z.0/28 where x.y.z.1 is address of an interface on their own network device, which should be a default gateway to our server, according to their words. There is an optical link between provider and optical converter on the side of server, and electrical link from converter to the server.

I have configured the server primary network interface this way:

ifconfig eth0 x.y.z.2/28 up

route add default gw x.y.z.1 netmask 255.255.255.240 dev eth0

But, when I try to ping x.y.z.1, icmp tells me that Destination host is unreachable iptables installed but policy is ACCEPT everywhere.

It's very interesanting that link is not showing any activity, by the LED diods on NIC. I tried other NIC, and it's the same case. I tried even on my laptop with windows OS, and I didn't get any reasonable notification, instead I got Network cable unplugged?!

But when I put the cable into the other server with Windows server 2003, NIC's LEDs show activity. That server is giving access to the internet only about 10 minutes after restarting, after it stops serving, probably NATing, for unexplained reasons to me . I don't have insight to win server, cause it's under password of other admin who is not available anymore, so it was the reason to build a debian server from scratch, but on the very beggining big problem is in front of me.

So, does anyone have an idea what is the cause of problem and how to solve it?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Couple things come to mind:

  1. MAC address learning. My home cable modem does this and once it's seen a MAC, it won't respond to any other MAC. Power-cycling the cable modem causes it to forget the MAC its seen so that I can use it with another system.
  2. Crossover cable/strightthrough confusion. You're using one when you should be using the other. I don't know for sure if this works, but I do know that Mac OS X(10.3, at least) will recognize when this is the case and adapt accordingly. It sounds like the Linux box you're using isn't doing this. It is not supposed to work that way, but Apple likes to make things easy for the end user; I would not be surprised if Microsoft or the NIC OEM does the same.
share|improve this answer

To add to Kevin's list:

  • Check for ethernet link
  • Check for ARP, consider using tcpdump or wireshark to check if there's any traffic
  • Ask if they require you to manually set link speed/duplex
share|improve this answer
1  
The third point may be the problem. I'll check. Thanks. –  Boban P. Dec 13 '09 at 13:46

First, I checked Kevin's second possible solution. It was straight-through cable, so this was not cause of the problem.

After that, I decided to do power-cycling. But when I've opened the rack, there was a huge mess in it, at least 10 network devices with mass of cables and wires. It was nothing labeled (I don't know why) so I concluded that it easier for me to change NICs between Debian and Win server and find out what will happen. If the MAC learning is a problem, this will solve it. But after I change NICs between servers, unexpected problem arised: kernel did not recognized a new NIC. This problem could probably be solved by adding some kernel modules, or in similar way, but with no working internet connection I couldn't find the proper way to do it. So I decided to reinstall Debian with new NIC in the box. After that, kernel have racognized the NIC, and it's LEDs start to show some activity. Finally, I coud ping x.y.z.1. So, link is ok.

But, when I've tried to ping a nameserver's IP in provider's network, I haven't got any response! I tried to traceroute a nameserver's IP, and I've got 4 hops, all inside provider's network, after i've got stars (* * * and last response * *). I tried to ping the second hop and the third hop, it was ok, but I didn't get any response when I tried to ping the fourth hop!

Is there any possible kernel parametres which I shoud set? Should I set some parametres inside sysctl.conf?

Anyway, thenks for the answers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.