Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem with Windows 7 RC (7100).

I frequently use a crossover network cable on WinXP with static IP addresses to connect to various industrial devices (e.g. robots, pumps, valves or even other Windows PCs) that have Ethernet network ports.

When I do this on Windows 7, the network connection is classed as an "Unidentified Network" in Networks and Sharing Center and the public firewall profile is enforced by Windows. I do not want to change the public profile and would prefer to use the Home or Work profile instead.

For other networks like Home and Work I'm able to click on them and change the classification. This is not available for unidentified networks.

My questions are these:-

  1. Is there a way to manual override the "Unidentified Network" classification?
  2. What tests are performed on the network that fail, therefore classifying it as an "Unidentified Network"

By googling (hitting mainly vista issues) it seems that you need to ensure that the default gateway is not 0.0.0.0. I've done this. I've also tried to remove IPv6 but this does not seem possible on Windows 7.

UPDATE

For those still having problems here is the answer to my issue and the possible reasons why:-

Win7 keeps a list of the networks you visit by (I am assuming, but don’t know for sure) the MACID of the device pointed to by the Default Gateway. The default gateway is usually the constant device in a network (i.e. the NAT or router) so can be used to uniquely identify one network from another.

The default gateway in the IPv4 properties panel must therefore point to an actual endpoint so windows can then keep track of it. If there is a device at the end of the Default Gateway windows will identify it and track it remembering its settings.

The ways you can therefore fool Win7 is to either point the default gateway to your own IP address, or the IP address of the target device you’re communicating with. This will have the side effect of expecting that target device to start routing packets for IP destinations that are outside your subnet. So some applications on Win7 will try to communicate with the internet, these will be passed on to the default gateway (either back you the same IP address or a target device that is not a router) and thus will eventually timeout because neither can route packets. Which you can usually live with. This gets slightly complicated when you mix a this type of connection with a real connection to the internet via WIFI. The wired network card usually has priority when routing because of the “interface metric” so some applications might not connect correctly.

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

I had the same problem in a Win 7 Ultimate, running in a VirtualBox VM, with Linux Mint 8 as host. After reading some answers here, I just added the default gateway to my static IP in Win 7 and set it to be the IP address of the VirtualBox adapter in my host OS. And that was it... It just worked and I was able to change that "Unidentified Network" that was bugging me...

share|improve this answer
add comment

Press WinKey+R, type "secpol.msc" without quotes. Then click Network List Manager Policies on the left, and then you should be able to change it from there.

share|improve this answer
1  
Thanks for this tip, I've now tried this (needed to wait until I swapped harddrives from usual XP install). This seems to be what I need to change but did not work on the two issues. It did not allow me to change the classification of the unidentified network and the options for making all unidentified networks private networks was ignored. Even after reboot. I will persevere to ensure I did not make any stupid mistake. Thanks again. –  Rhys Jun 1 '09 at 8:55
    
This doesn't seem to do anything. I rebooted several times and none of the options seemed to make a difference. –  Joseph Sep 13 '09 at 15:20
    
@Rhys I can partially confirm your observation, i.e. the policy setting User permissions does not have the desired effect to enable the UI. However, the policy setting Location type does apply, i.e. setting it to 'Private' will result in a 'Work network' immediately at least. It is worth noting that M4dRefluXs instructions do work out on Vista though, i.e. the policy setting User permissions does affect the UI as expected (though what you want is default there anyway). –  Steffen Opel Jun 17 '10 at 9:22
    
@M4dRefluX Could you please comment on whether your instructions did in fact work out on Windows 7 for you or have just been tested on Vista (see my comment above for the background)? Getting this nasty issue properly documented (or ideally sorted) would benefit literally hundreds of thousands of users - Thanks! –  Steffen Opel Jun 17 '10 at 9:39
1  
Windows cannot find 'secpol.msc'. Make sure you typed the name correctly, and then try again. Windows 7 home premium SP1. –  Soonts May 6 '11 at 22:41
show 2 more comments

I fixed it after many hours. Here's my situation and my workaround. Hope it helps.

At home I have 2 broadband internet connections. One is ADSL (20 Mbps) behind a router with DHCP and the second is Cable (120 Mbps) directly behind the modem (public IP to the computer). Both lines go to my Mediacenter-PC which is always on and runs Kerio Control (https://www.kerio.nl/products/control/). Kerio is a software based router that supports link fail over. As you can see, having a working internet connection is critical for me. A third network interface card is configured with a static IP (192.168.3.1), Kerio runs a DHCP-server on it and is connected to my home network.

I did two things, but I think the real trick was the second. Anyway, the first step was that I ran the Powershell script mentioned at http://blogs.msdn.com/b/dimeby8/archive/2009/06/10/change-unidentified-network-from-public-to-work-in-windows-7.aspx . This changes all Unidentified networks to Work-networks. Okay, not unidentified anymore but Homegroup won't startup on Work networks!

Windows 7 detects your home network by looking at it's gateway. Because I was running the gateway/router on the same PC, I didn't fill out the gateway IP. So it won't give the popup to identify the network and you won't be able to set it to Home manually. I also failed to do it in script.

Setting the gateway to the static IP address also didn't work because Windows removes the gateway address (192.168.3.1) after pressing OK. My trick: Add a second IP to the NIC. E.g. 192.168.3.254. Then leave the primary IP (in my case 192.168.3.1) and set the gateway IP to the second IP (192.168.3.254). A few secs later, Windows will raise the popup and select 'Home network' and you're done!

share|improve this answer
add comment

I came across this article while searching on this problem. And i found an article posted here http://knoxious.com/2010/04/28/windows-7-unidentified-network-fix/ and it seems to have solved my problem!

I hope it works for those who are still having problems as well.

share|improve this answer
add comment

protected by splattne Dec 23 '10 at 18:03

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.