Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using VSTS 2008 + C# + .Net 3.5 + IIS 7.0. I have created a new web site and put an html file into the directory. And when I use browse function in IIS manager to browse the html file, I met with the following error, any ideas what is wrong?

BTW: I am very confused about unauthorized error since I run the worker process under administrator account. From the error message, I am confused why the logon method is anonymous and not using administrator account?

HTTP Error 401.3 - Unauthorized
You do not have permission to view this directory or page because of the access control list (ACL) configuration or encryption settings for this resource on the Web server.

Module IIS Web Core 
Notification AuthenticateRequest 
Handler StaticFile 
Error Code 0x80070005 
Requested URL http://localhost:80/a.html 
Physical Path C:\test\simplehosttest\a.html 
Logon Method Anonymous 
Logon User Anonymous

thanks in advance, George

share|improve this question

Just because the AppPool identity account is an Administrator account, it doesn't mean that Anonymous users access resources as that account.

  1. Select your website (or the web-server/top-level)
  2. In the feature pane, select Authentication
  3. Right-click the "Anonymous Authentication" provider and select "Edit"
  4. If you want the AppPool identity to access the files for anonymous users, select "Application pool identity"
share|improve this answer

Verify the permission on C:\test\simplehosttest folder. Your best friend is which will let you know what is casuing Access Denied.

Hope this helps,

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.