Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Help!

I'm trying to install PowerShell 2 on my main machine. Its running Vista x64 Home Premium. I'm running on an account with admin privileges.

I've tried asking this question on Super User, but no answers to date.

Here's what I've done so far:

  • Downloaded the Windows Management Framework core package
  • Run the install
  • Got the message: "The update does not apply to your system"
  • Googled the problem and found out that I had to uninstall PowerShell 1 first
  • Uninstalled PowerShell 1 and re-booted.
  • Re-run the WMF installer, and get "The update does not apply to your system"
  • Google some more with no-so-useful results
  • Ask question on ServerFault, no replies/answers

Which brings me to here. Any ideas what might be going wrong?

I should also add that I have not installed Vista x64 SP1 on my system. Automatic updates tried to install SP1 but failed with no specific error message. Since my system works without SP1, and I'm waiting for my next machine (which will run Win7), I don't particularly feel inclined to install SP1.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Powershell 2.0 and associated components need at least SP1 on Vista. You should really run SP2 though, there are a ton of improvements.

http://support.microsoft.com/kb/968929

share|improve this answer
    
Fine!! I'll try to upgrade to SP2. Thanks for the info. Nice error message, eh? –  kmontgom Dec 13 '09 at 18:41
    
Also ensure you have the right installer, there are several depending on target OS and processor architecture. –  Richard Dec 14 '09 at 17:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.