Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i have downloaded JBOSS 5.1 and unzipped it to c:\jboss-5.1.0.GA. I have installed java jdk1.6.0_17 and i am using Windows XP SP3 (Dev-Environment) I have two problems.

I am not able to use it as a service. I get the local JBoss website (http://127.0.0.1:8080) when i start Jboss manually by running c:\jboss-5.1.0.GA\bin\run.bat. I can install the service (service.bat install) and it starts without errors but the local JBoss website (http://127.0.0.1:8080) is not reachable. I also tried the tanuki service wrapper without success.

The other problem concers EAR deployment. When I run JBoss (manual start) i get the following error for coldfusion 9:

java.lang.RuntimeException: org.jboss.deployers.client.spi.IncompleteDeploymentException: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):

*** DEPLOYMENTS IN ERROR: Name -> Error

vfsfile:/C:/jboss-5.1.0.GA/server/default/deploy/cfusion.ear/ -> org.jboss.deployers.spi.DeploymentException: URL file:/C:/jboss-5.1.0.GA/server/default/deploy/cfusion.ear/cfusion.war/ deployment failed


DEPLOYMENTS IN ERROR:
  Deployment "vfsfile:/C:/jboss-5.1.0.GA/server/default/deploy/cfusion.ear/" is in error due to the following reason(s): java.lang.SecurityException: Seed must be between 20 and 64 bytes. Only 8 bytes supplied.

        at org.jboss.profileservice.management.upload.remoting.StreamingDeploymentTarget.invoke(StreamingDeploymentTarget.java:313)
        at org.jboss.profileservice.management.upload.remoting.StreamingDeploymentTarget.start(StreamingDeploymentTarget.java:190)
        at org.jboss.profileservice.management.upload.DeploymentProgressImpl.start(DeploymentProgressImpl.java:231)
        at org.jboss.profileservice.management.upload.DeploymentProgressImpl.run(DeploymentProgressImpl.java:88)
        at org.rhq.plugins.jbossas5.util.DeploymentUtils.run(DeploymentUtils.java:120)
        at org.rhq.plugins.jbossas5.AbstractManagedDeploymentComponent.invokeOperation(AbstractManagedDeploymentComponent.java:181)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:482)
        at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
        at java.util.concurrent.FutureTask.run(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
Caused by: org.jboss.deployers.client.spi.IncompleteDeploymentException: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):

I already tried to pass this to the JVM:

-Dcoldfusion.disablejsafe=true

But it does not help.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I ran into that same problem. Open the service.bat file and look for 'set JAVA_OPTS=-Xrs' REM it out then save and close.

Below is a good guide on how to deploy CF9 on JBoss.

http://help.adobe.com/en%5FUS/ColdFusion/9.0/Installing/WSc3ff6d0ea77859461172e0811cdec18c28-7fbd.html

Hope it helps :)

share|improve this answer
    
i am using glassfish v3 now, much easier to setup :) –  mrt181 Dec 16 '09 at 11:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.