Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Setup:

  • 1 PC with Windows XP SP2
  • 1 network card connected to a LAN which provides internet access (LAN_CONN)
  • 1 network card connected to a VPN link set up by the provider (VPN_CONN)
  • VPN_CONN is set up as a LAN connection, not as a VPN one (the provider gave me an ip and a gateway to connect to).

Problem:

VPN_CONN works fine when connected but I lose access to the internet provided by LAN_CONN.

I have searched for solutions regarding this problem but none of them helped me solve it. Everything I found assumes that VPN_CONN is set up as a VPN connection. Can someone help me solve it? Thank you in advance.

I may have been a bit unclear in defining the problem but i'll try to provide more information if needed.

share|improve this question
    
Do you do anything special to the PC beyond standard configurion (IP, mask, Gateway) the VPN NIC? Do you install VPN software, or setup the VPN NIC in an atypical manner? –  tomjedrz Dec 14 '09 at 17:10

3 Answers 3

On the properties of your VPN connection, click on TCP/IP and then in properties again. Search for an advanced button. There is a checkbox that says something like: Use this as default gateway. Or maybe something related to gateway. I don't know exactly the option because I'm in front of a linux now. After find and unmark this checkbox, click ok on every window and then connect to your VPN. This should work.

Ps.: This configuration is done on the client side.

share|improve this answer

I have similar setup, where 1st network card is for intranet only (10.0.x.x) and 2nd one for internet. After installing 2nd card I faced the problems when Windows was routing all the internet traffic trough 1st network card, but the intranet has very limited internet connection.

Solution:

This batch file being executed during startup:

route DELETE 10.0.0.0
route DELETE 0.0.0.0
route ADD 10.0.0.0 MASK 255.0.0.0 10.0.0.1
route ADD 0.0.0.0 MASK 0.0.0.0 192.168.1.1

Where 10.0.0.1 is the gateway for intranet, and 192.168.1.1 for internet.

Notes:

If this is not your case, I recommend you analyzing your routing mechanism by issuing following command:

route print

Or, trace your traffic by some handy tool like wireshark.

share|improve this answer

The issue is that when you're connecting to your VPN the routing table on your PC is updating to use the VPN as a default gateway for everything.

What you're trying to do is called "split tunnel access" and it would require adding a route to your LAN default gateway that overrides the VPN gateway.

The cable guy at microsoft has an article on ways of setting this up:

http://technet.microsoft.com/en-us/library/bb878117.aspx

It should also be noted that depending on the VPN solution in use you may be disconnected as soon as your routing table changes.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.