Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am installing VSTS 2008 SP1 on Windows Server 2003 R2 32-bit, which has already installed with VSTS 2008 successfully before. I met with the following error (from install log, at almost the end of install progress from progress bar), any ideas what is wrong?

(IronSpigot::MsiExternalUiHandler::InstallMessageErrorHandler) Returning IDOK. INSTALLMESSAGE_ERROR [Error 1718。File C:\WINDOWS\Installer\35d33.msp Rejected by digital signature policy]

thanks in advance, George

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Not run into this problem with Windows Server 2008 or above, however I have had problems with large Windows Installer packages under Windows XP and 2003. Try the workarround from KB925336:

To work around this problem, change the PolicyScope registry value to 1 before you try to install the package. To do this, follow these steps.

That said the above has never actually worked for me, the second workaround on that page did though:

  1. Click Start, click Run, type control admintools, and then click OK.
  2. Double-click Local Security Policy.
  3. Click Software Restriction Policies.
  4. Under Object Type, double-click Enforcement.
  5. Click All users except local administrators, and then click OK.
  6. Restart the computer.

Remember to revert the changes (Delete the Software Restriction Policy, or change it All Users) when you are finished installing VSTS.

share|improve this answer
    
Thanks! "never actually worked for me" -- confused. You mean the 6 steps never work for you or? –  George2 Dec 14 '09 at 15:46
1  
Sorry, I wasn't being very clear. I meant the first part of the Workarround never really worked for me, configuring the Software Restriction policy did however work. I was referencing the full Workarround for completeness. –  Richard Slater Dec 14 '09 at 15:48
    
You mean the 6 steps work for you? –  George2 Dec 14 '09 at 15:49
1  
Yes [This comment does not require 15 characters] –  Richard Slater Dec 14 '09 at 15:57
    
Thanks, question answered! –  George2 Dec 14 '09 at 16:17
show 1 more comment

According to this KB Article, the error is down to the fact that there is not enough contiguous memory for Windows Installer to verify the msi package is correctly installed. The article provides a hot fix for server 2003, but nothing for server 2008. I would suggest ensuring there is a good amount of free memory on the server when you run the installer.

There is also a workaround to disable checking of the signature, the steps are listed here.

share|improve this answer
    
"ot enough contiguous memory for Windows Installer to verify the msi package is correctly installed." -- confused. I monitored only a small portion memory is used from performance tab of task manager. Why still not enough memory? –  George2 Dec 14 '09 at 15:48
1  
Well contiguous memory would be blocks in memory that are adjacent to each other, it could be this is not available, have you tried rebooting? If that doesn't work I would suggest following the workaround just to get this installed. –  Sam Dec 14 '09 at 15:56
    
Good to learn, thanks! –  George2 Dec 14 '09 at 16:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.