Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Running Ubuntu 9.10 and I am trying to install the php5-mcrypt module is killing me softly. I am not sure what else to try. Anyone have any idea?

Here is the error i get:

sudo apt-get install php5-mcrypt     Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  php5-mcrypt: Depends: libltdl3 (>= 1.5.2-2) but it is not installable
               Depends: php5 but it is not going to be installed or
E: Broken packages

Sources List looks like:

## main & restricted repositories
deb karmic main restricted
deb-src karmic main restricted

deb karmic-security main restricted
deb-src karmic-security main restricted

## universe repositories
deb karmic universe
deb-src karmic universe
deb karmic-updates universe
deb-src karmic-updates universe

deb karmic-security universe
deb-src karmic-security universe

deb stable all
deb-src stable all

deb stable all
deb-src stable all
share|improve this question

3 Answers 3

up vote 2 down vote accepted

I had the same problem in Ubuntu 9.10 server (I also use php53 dotdeb repositories).
I resolved adding this line to /etc/apt/sources.list

deb lenny/updates main

Then you should execute:

gpg --keyserver --recv-keys 9AA38DCD55BE302B

sudo apt-key add .gnupg/pubring.gpg

sudo aptitude update

sudo aptitude install libltdl3

Now after you restart apache, ...

sudo service apache2 restart

... PHP 5.3 will be working fine with mcrypt extension enabled.

share|improve this answer
thank you for that. it worked. –  NTulip Jan 15 '10 at 15:22
Excellent - Thanks for the info. It fixed my phpmyadmin on Ubuntu 9.10 using the dotdeb php5.3 sources. –  Tom Apr 19 '10 at 10:46
Update for new Squeeze.… –  robregonm Feb 21 '11 at 17:03

I'm thinking that the sources you use have some sort of conflict. From your error it looks like you need to uninstall the version of libltdl you current have and install this one:

It also complains about php5 - do you have php5 installed already via deb?

Your additional repository may be causing version conflicts:

I think the standard Ubuntu repositories include php5 and php5-mcrypt, so you shouldn't need any additional repositories unless you are using a version that is newer than the one you can get with the built in Ubuntu ones. Of course these are all guesses, it is highly system dependent and I have no idea what you have installed on the system. Hope that helps you a little bit! :)

share|improve this answer
i got php5 installed and for wordpress etc. it's working fine. –  NTulip Dec 14 '09 at 19:19
funny - "Package libltdl3 is not installed, so not removed". The package "libltdl" could not be removed since it didn't exist –  NTulip Dec 14 '09 at 19:21
It might be called ltdl-dev - do a search for the package that is currently installed. dpkg -l|grep ltdl should do the trick. –  Dave Drager Dec 14 '09 at 20:42

You can install libltdl3 package manually from debian:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.