Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an application that automates the creation of powerpoint files in an ASP.NET environment. This requires that I install powerpoint on the server and also set permissions in the DCOM configuration snap-in (dcomcnfg) to give permissions to the launching user ([DOMAIN]\ASPNET in this case) to run the application.

I have this setup running successfully on several Win2k3 machines. I am configuring my first Win2k8 machine and after installing powerpoint on the server, the "Microsoft Powerpoint Presentation" node in DCOM config is not showing up. Other installed Office apps are showing (Excel, Graph, etc...), just not Powerpoint.

So when I attempt to run the application, I get an "Access denied" error, which is exactly what I would expect. The user doesn't have permission. Therefore, access denied. The specific error log entry is:

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID {91493441-5A91-11CF-8700-00AA0060263B} to the user [DOMAIN]\ASPNET

I searched the entire list for the CLSID, too, thinking maybe the name wasn't loading properly. No dice.

I also re-ran the setup program for Office thinking maybe there would be some option or something I unchecked in the custom setup options, but I saw nothing that looked helpful.

I'm flummoxed. Can anyone out there suggest something to help me get Powerpoint to show up in the list of DCOM applications?

Many thanks.

share|improve this question
add comment

2 Answers

You're probably running on a 64-bit machine, which means you need to run:

mmc -32

from the start > run dialog, then choose File > Add/Remove Snap-in, and add Component Services. From there, all the Office applications should appear.

share|improve this answer
add comment

you also should look to the localized name of DCOM config entry (if you have MUI version of Office). In my case instead of "Microsoft Office Powerpoint Slide" it was "Слайд Microsoft Office Powerpoint Slide" because of Russian version of Office and it was in the end of the list.

Best Regards.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.