Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My RPM database is shot, neither rpm or yum works. Supposedly "rpm --rebuilddb" will fix it, but it doesn't in my case. This server has three sister servers that are basically identical, and have working RPM databases. I tried copying /var/lib/rpm/ from working server to the sick one, but that didn't fix it. Any ideas of how I can use good server's rpm to fix the sick one?

share|improve this question

Try removing /var/lib/rpm/__db.* before doing an rpm --rebuilddb.

share|improve this answer

That didn't work for me. After some googling, I tried this:

rm /dev/urandom mknod -m 644 /dev/urandom c 1 9

After that, rpm --rebuilddb did work. Unfortunately, I don't know what happened to my /dev/uraqndom. :(

share|improve this answer

rm /dev/urandom ;mknod -m 644 /dev/urandom c 1 9

works for me as well

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.