Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm currently upgrading a Samba file server (from 3.0.23d to 3.4.3). I have a problem on the Windows client side: if the client was accessing a UNC path or mapped drive from the Samba server before the upgrade, then after the upgrade those paths or drives are not accessible.

However, I can consistently resolve the client side problem for good by rebooting the client and then re-mapping all of the mapped drives. The problem appears to be related to the client's "memory" of the pre-upgrade Samba server, which the reboot and re-map clears.

I have the same issue and same fix on Windows XP SP3 and Windows Server 2003 SP2.

This question is specifically: is it possible to reproduce the benefits of the Windows reboot without actually rebooting the client?

I have tried restarting various Windows services, disabling and enabling the network, logging out and back in again, but nothing except a reboot appears to do the trick.

share|improve this question
add comment

5 Answers

Do you mind having to remap the drives without a reboot? From a command prompt you can:

NET USE /DELETE *

That will remove all the mappings. Then you can set them back up again. It would be interesting to see what a NET USE (which will list all the mappings) looks like both before and after.

Additionally if all the mappings should be the same on each box you could just write a quick batch script to net use /delete followed by a net use for each of the mappings that should exist. Hope that helps.

share|improve this answer
    
That would be a good solution, but unfortunately it doesn't work in this case. The client issue stops the drive from being re-mapped: in the same way that the user can't browse (e.g. \\server\share), they also can't map a path that they were using prior to the upgrade. Following a reboot, they are able to re-map the drives. –  Tom Shaw Dec 15 '09 at 5:06
    
Did you try a net use /delete * before trying to remap it though? In theory this should clear out all the mapping information the same way a reboot would. –  Dave Holland Dec 15 '09 at 5:36
    
I have tried that with no success. I believe that the "caching" that is going on happens at a different level, given that browsing with a UNC path also doesn't work even without a mapping. –  Tom Shaw Dec 15 '09 at 9:05
    
Did you use net use /persistent when you set up the drive mappings initially? –  Jimmy Shelter Dec 15 '09 at 11:17
add comment

What about if you try restarting the Distributed Link Tracking Client service?

share|improve this answer
    
Awesome; this helped clear out "ghost" file share entries for me. I was accessing a share, and it was showing a bunch of folders I had deleted. –  Adam Brand Aug 23 '10 at 21:59
add comment

Try looking in the Stored User Names and Passwords applet in Control Panel on the client machines for credentials that have been stored for the Samba shares and change the credentials there.

share|improve this answer
    
On Windows Server 2003, the Stored User Names and Passwords dialog is empty. On Windows XP, I can't find it. Note that all Windows clients are members of the AD domain, as is the Samba server. –  Tom Shaw Dec 15 '09 at 4:09
    
Right, sorry. On Windows XP it's in the advanced properties of the user account. –  joeqwerty Dec 15 '09 at 12:00
add comment

I would try restarting the 'Workstation' Service.

share|improve this answer
    
Didn't work unfortunately! –  Tom Shaw Dec 15 '09 at 5:27
add comment

Fire up a command prompt and type "net use \\servername /d"

Ignore the shares you may have mapped, this will delete the connection to the server, including any cached authentication.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.