Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Using Amazon's AWS, I created a 1 GiB volume. I attached it to a running instance and formatted it with ext3. I then mounted it and and used df -h to report its size. It's apparently 414G. I'm already using 2G of it.

What's going on here?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

It could be that you tried to attach the volume to a device name that was already in use for ephemeral storage.

On some images I've used the boot device /dev/sda and /dev/sdb through /dev/sde is ephemeral storage. When I tried to attach an EBS volume as /dev/sdb I received no error from the AWS management console, but the volume did not attach on /dev/sdb.

share|improve this answer
    
Yup, that was it! thanks. –  aidan Jan 8 '10 at 11:29

Sounds like an error. :)

If you don't have any data on it, you might want to just ditch that volume and try again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.