I want to force the install system on debian linux, apt-get, to install unstable (i.e. a later version) of a package, later than the stable one recognised by the debian package maintainer.
This because I want to take advantage of new features in the later release.
I have tried the combinations of the following but none force a later version of what I want:
- the apt-get -t unstable option
- editing /etc/apt/apt.conf APT::Default-Release "unstable";
- editing /etc/apt/source.list ftp.uk.debian.org/debian unstable main
The following is optional, if you are interested (!): I have given some specific background as to what I am trying to achieve below.
My Specific situation in detail
I want gcc 4.4 on my Debian 4 Etch system but apt-get reports latest as being 4.1.
It reports 4.1 as this is the latest stable release supported by the central Debian package maintainer.
Later versions are regarded as unstable.
I need 4.4 because it I need to install the PerlMagick module required by some graphical features in my bugzilla-3.4.4 installation.
Without 4.4 I get an error during a make/compile stage in the Perl module install for the PerlMagick module: "unrecognised command line option "-fopenmp"" - this error is about multi-processor support and is available in the latest 4.4 version of gcc but not in 4.1 which is what the debian package maintainer regards as the latest stable.
I'm hoping that if I can get gcc 4.4 on my machine then this error will not appear if I re-run the Perl install for the PerlMagick module and the graphical features will be enabled.