Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to upgrade the firmware on a Linksys/Cisco RV082 router using Mac OS X and it's not working. The current firmware version is (Jul 28 2005 18:12:59), and I've tried upgrading to both 1.3.98-tm (Jun 20 2008 18:37:29) and (Feb 20 2009 15:15:20).

Steps Taken to Try to Upgrade Firmware

  1. Logged into the RV082's Web Management site using Safari
  2. Navigated to System Management -> Firmware Upgrade
  3. Select "Choose File" and select the desired firmware file
  4. Select "Firmware Upgrade Right Now"
  5. Waited for over 10 minutes without success
share|improve this question
up vote 1 down vote accepted

After trying various things, such as being directly connected to the RV082 instead of using wireless and disconnecting all other connections to the RV082 including the WAN connection to the Internet, I tried Firefox. Approximately two minutes after clicking "Firmware Upgrade Right Now", the RV082 rebooted and the firmware was updated.

Looks like Safari was the culprit.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.