Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm running IIS7.5 on Windows 7, and it's got IIS6 Compatibility installed due to requirements from our current product installer.

After successfully installing our product, I realized I needed to reinstall some other software that it relies on. I uninstalled our product, reinstalled the dependency product, and tried to reinstall our product. Our MSI failed with "Failed to write data to metabase key. (-2147023584 /LM/W3SVC/1/<app name> )". The MSI log shows

Error 26104. Failed to write data to metabase key.  
(-2147024713   /LM/W3SVC/1/Root/<app name>)

Googling this problem doesn't help much. Does anyone know how I can fix it? Is it permissions related?

Thanks for any suggestions.

share|improve this question
    
Do you have the domain user account in the local admingroup? –  Luke99 Dec 16 '09 at 18:12
    
Oh, yeah I should have mentioned, I'm in the admin group, and I'm running the MSI from a command prompt as administrator. –  womp Dec 16 '09 at 18:14
    
Do you have Anonymous Access and Windows Integrated enabled in Default Website? –  Luke99 Dec 16 '09 at 20:05

1 Answer 1

up vote 0 down vote accepted

Gah, I finally solved it. I hope this helps someone else out.

It came down to the "other software" that our stuff relies on, in this case, ArcGIS Server. The uninstall/reinstall of it somehow managed to leave duplicate entries on multiple paths in the applicationHost.config file for IIS.

There were four entries:

<add name="ESRI_mapHandler" path="ESRI.ArcGIS.ADF.Web.UI.WebControls.MapHandler.ashx" verb="*" type="ESRI.ArcGIS.ADF.Web.UI.WebControls.MapHandler, ESRI.ArcGIS.ADF.Web.UI.WebControls, Version=9.3.1.3000, Culture=neutral, PublicKeyToken=8fc3cc631e44ad86" preCondition="integratedMode" />
<add name="ESRI_tileHandler" path="ESRI.ArcGIS.ADF.Web.DataSources.ArcGISServer.TileHandler.ashx" verb="*" type="ESRI.ArcGIS.ADF.Web.DataSources.ArcGISServer.TileHandler, ESRI.ArcGIS.ADF.Web.DataSources.ArcGISServer, Version=9.3.1.3000, Culture=neutral, PublicKeyToken=8fc3cc631e44ad86" preCondition="integratedMode" />
<add name="ESRI_mime" path="ESRI.ArcGIS.ADF.Web.MimeImage.ashx" verb="*" type="ESRI.ArcGIS.ADF.Web.ImageHandler, ESRI.ArcGIS.ADF.Web, Version=9.3.1.3000, Culture=neutral, PublicKeyToken=8fc3cc631e44ad86" preCondition="integratedMode" />
<add name="ESRI_mime91" path="ESRI.Web.Controls.MIMEImage.aspx" verb="*" type="ESRI.ArcGIS.Server.WebControls.ImageHandler, ESRI.ArcGIS.Server.WebControls, Version=9.3.1.3000, Culture=neutral, PublicKeyToken=8fc3cc631e44ad86" preCondition="integratedMode" />

These entries were duplicated in the

 <location path="Default Web Site">
    <system.webServer>
      <handlers>

and the

 <location path="" overrideMode="Allow">
    <system.webServer>
      <handlers accessPolicy="Read, Script">

paths of the config file. Removing the four entries under the Default Web Site path solved multiple issues!

I guess IIS was attempting a metabase write, but because the config file was bad, it just wasn't happening in certain cases.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.