Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm looking to add a second IP address to IIS so that I can run two sites with different SSL certificates.

When I added one on my play box and ran ipconfig /registerdns both addresses were registered in DNS with the server's name. So, I deleted the A record for the new IP address and rebooted. That also registered both names.

So, then I went into the network config for the adapter and, on the DNS tab, unchecked "Register this connection's addresses in DNS". I deleted the A record for the new IP address again and re-ran ipconfig /registerdns. This time, it deleted the A record for the old IP address and didn't created one for the new address.

Neither of these is what I want: I want the main IP address to be registered and refreshed automatically as a dynamic DNS record and the second IP address to be registered and managed as a static address. Is there any way to achieve this?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

To do this with host headers you're going to probably need a wildcard ssl cert, and as you're adding a second IP to the nic i assume you do not have one of these.

An easier (cheaper?) method would be to assign both IP addresses as static and create the dns records manually.

This way you could assign one IP adress per cert and not have to worry about dns updates.

Is there a strong case for having the second IP dynamic?

Another alternative is adding a new physical (or virtual if you're on virtual infrastructure) to the box and assigning the new ip and turning off dns reg on that.

My personal preference (other than a wildcard cert and host headers) would be to turn off dynamic addressing and registration completely for a web server.

share|improve this answer

It shouldn't matter if it gets registered in your DNS multiple times. You can use host headers in IIS to configure which website will respond to each domain. So long as each of the DNS hostnames map to the correct ip address and the website is listening on that address then it will serve the correct webpage.

share|improve this answer

Try un checking "Register this connection's addresses in DNS" in the other IP address setting tab and see.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.