Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm facing an odd issue with the IIS Manager on Windows 7 (x64).

At home, I have Win7 Professional, and when I check my IIS manager icon in the start menu, I see it links to


When I launch this from the command line, it works like a charm.

At work, however, I have Windows 7 Enterprise (x64), and when I check my link in the start menu, the entry is exactly the same. If I click on it - it works like a charm.

Now if I'd like to launch it from the command line (cmd.exe or TakeCommand), however - the file just isn't there - a

DIR %windir%\system32\inetsrv\*.exe

shows a number of files, including a "inetmgr6.exe" - but no "inetmgr.exe" - and of course, I can't launch it either :-(

Strangely enough, when I look at the directory %windir%\system32\INetSrv in Windows Explorer or Windows Powershell, I SEE the INetMgr.exe file and I can launch it - no problem.

What the **** is going on here? How can I find the INetMgr.exe from my classic command line and launch it from there??

UPDATE: ok, some updates. On my work laptop, the INetMgr.exe file appears to really be located in a directory called c:\windows\syswow64\inetsrv (I'm recalling from memory, so don't quote me on the directory name - something like that). I can see this if I search for it in e.g. Powershell or Windows 7 Explorer.

However, from a "classic" command line like cmd.exe, it appears to be in c:\windows\system32\inetsrv ..... hmmm.... trouble is - even though I now know where the file really is, I cannot access that directory from my classic command line - not even if I'm running cmd.exe as admin with elevated privileges....... so I know where the file is, but that still doesn't solve my problem :-(

share|improve this question
up vote 3 down vote accepted

That's an interesting one. Try launching your command prompt with elevated privileges in case UAC is fighting with you. My only other guess is that %windir% is set differently in your path for the command prompt somehow. Try navigating to it with the explicit path. Also, try creating a test file like 'test.txt' from your command prompt and make sure that it shows up in Windows Explorer, to make sure that the paths between the two apps aren't messing with you.

share|improve this answer
Thanks Scott - I am already running my command lines as "Administrator". I'll try the other things you mentioned and I'll report back. – marc_s Dec 19 '09 at 16:58

FWIW - I was seeing exactly the same problem on my Windows 2008 R2 "desktop". I never did find a fix or an explination.

But a workaround for me was to copy C:\Windows\System32\inetsrv\InetMgr.exe to a new folder (e.g. "E:\Apps\IIS\InetMgr.exe"). Now I can execute it from a command line in this location, UAC comes up, and all works fine from there on.

share|improve this answer

I've a similar problem, I'm using windows 7 64bit, I try to find the InetMgr.exe using a program like Chrome (using upload window) or notepad++ (File-->Open) but I don't see the file.

If I try to find it using windows original notepad I see it. Using CMD the file is visible. If I copy and paste the file in the same dir... it is not visible to other programs. If I rename the file (test.txt)... the file is still not visible...

It seems that the file is visible to other Operating system programs (Explorer,notepad) but not to third party software (Chrome,notepadd++,winamp ecc)

In all searches I've used the . search pattern. In all searches w3wp.exe and InetMgr6.exe are visible... but InetMgr.exe not.

In the directory C:\Windows\SysWOW64\inetsrv the file is not present.

How is it possible?


Here is the answer :

if you ask a 32 bit application to open c:\windows\system32\task.xml it will get redirected to c:\windows\syswow64\task.xml and fail to find the file, since it doesn't exist. The reason it works when you rename it to .txt is that it ends up opening in a 64 bit copy of notepad, which sees the file correctly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.