Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have enabled the setting in squid (in pfsesnse) where any file which is greater than 50MB should not be downloaded.

I tried downloading in IE and it comes with error that security setting does not allow you to download that file.

But when i tried same in FF it allows me to download any file size.

Why does Firefox bypass the proxy server?

share|improve this question
up vote 0 down vote accepted

Is Firefox setup to use the proxy? Can it get to the internet without using the Proxy? (the answer seems to be yes. Check the Firefox preferences, specifically Advanced --> Network --> Settings. By default, Firefox does not use or detect proxies (at least my local copy does not).

share|improve this answer
I have manually inserted proxy setting like http and port 3128 but still it downloads everything – John Dec 18 '09 at 4:26
Try restarting Firefox, and clearing the Firefox cookies/cache. – Joe Internet Dec 18 '09 at 5:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.