Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Background:

I have a fresh copy of Windows 7 Professional x64 on a Dell Latitude E6500. The laptop has 8GB RAM, 250GB drive, and all Intel peripherals (net/wifi/graphics). All available Windows updates, as well as hardware drivers are installed. The IT folks where I work joined the computer to our Windows 2003-based Active Directory domain. There are no errors in any logs that we've looked at, and Group Policy templates appear to have applied properly.

Problem:

Every time I turn on or reboot the computer, it takes between 2 to 10 (all times are actual) minutes after successfully typing my username/password to get to my desktop. My login script does not always run. Sometimes I get a black screen, and a couple of minutes later the login script will pop up and take up to 10 minutes to complete. I can get around this by hitting cntrl-shift-esc and running explorer.exe from the Task Manager. The login script continues to hang, but I can minimize it and go on about my business. Either way, it generally throws errors prior to completing. I often get slow or failed connectivity to Exchange via Outlook. When I bring up printer dialogs, they take several minutes to populate, and block the calling app while doing so. Copies to SMB shares are very slow. On my home network, everything works fine. On both the work network and home network, I can use remote internet resources just fine. Web pages pull up, remote VPN's are fine, I can max out bandwidth on SpeakEasy Speed Test. I can get almost max bandwidth transferring FTP/HTTP over a LAN. Another symptom of the problem is that when I first log in, the work network shows as "Identifying" for a long time in the Network and Sharing Center, and will often then change to the name of the work domain, but say "Unauthenticated Network". Note that this computer previously ran Windows Vista with none of these problems.

Attempts to Fix:

  • Installed the Win7 admin pack
  • Uninstalled/reinstalled all hardware drivers
  • Verified Active Directory DNS settings (Vista works relatively well on the same network)
  • Reset all TCP/IP settings on all adapters using the netsh commands to do so
  • Disabled ipv6 on all adapters
  • Disable wifi adapter while on work network
  • Locked the network card to 100/Full, 1000/Full; also tried Auto
  • Added various important addresses to hosts file (exchange, dns, ad) -- removed when didn't help
  • My background is a jpeg (sounds unrelated but there is apparently a win7 login bug related to solid color background)
  • More I have forgotten

The IT staff at my company indicated they believe this is due to having Windows 2003 AD servers and not having any Windows 2008 R2 AD servers. Other than that, they have no advice or assistance to offer other than a rebuild (already tried that once with similar symptoms), or downgrade to Vista.

Any thoughts out there?

share|improve this question
2  
I know you've checked your DNS settings, but it does smell of being a DNS problem. Try performing an nslookup on the FQDN of your domain (e.g. 'nslookup yourdomain.local'). Check that the output exclusively matches the list of DCs on your domain. –  Bryan Dec 18 '09 at 22:11
    
I did the check. We have two DC's. When I do nslookup on our domain, I get the IP for each of these two controllers on all known subnets. There are no IP addresses returned for servers other than the two DC's. –  Jeff Dec 30 '09 at 15:47
    
edit: I also did a tracert on these, and they all come back in <1ms –  Jeff Dec 30 '09 at 15:54
add comment

5 Answers

This problem is apparently rooted in the fact that we have multi-homed domain controllers. Kudos to @Bryan for sniffing out the DNS aspect of it. The symptoms are explained by our DNS reporting all available IP addresses for the DC's back to the Windows 7 client. The Windows 7 client is apparently interpreting this as a DNS round-robin situation. If it happens to get an IP its subnet, it works ok. If it gets an IP on different, or un-routable subnet, it fails. It looks like WinXP and Vista correctly pick the IP on the local subnet first, and ignore the rest of the IPs.

Our IT staff is currently working around this by setting up limited host files for the multi-homed DC's, but I don't think that will be the permanent solution.

Microsoft has various things to say about this here:

It's been mentioned on a couple of forums here:

share|improve this answer
    
DCs shouldn't be directly connected to two networks. There's reasons there are "best practices" for DC that are very strict, this is one of those reasons. If one of the NICs isn't on the "internal" network then it should have the "Register this address with DNS" unchecked in the IPv4 Properties. –  Chris S May 20 '10 at 1:05
add comment

Disclaimer: I don't know windows, I don't use windows, and I am not a windows sysadmin...

BUT:

In the past I have seen these 2 things cause A LOT of people problems:

1) Do you have a bunch of networks drives mapped but that are unreachable?

2) Do you have an roaming profile and a HUGE amount of stuff on your desktop?

share|improve this answer
1  
I had 10 minute boot times until I deleted my 13 unreachable network drives. –  Stefan Kendall Dec 18 '09 at 22:48
    
I have neither of these. My desktop is empty. I put all my data on a separate data partition, and rarely leave stuff on the desktop. I have no permanently mapped drives. Long ago I wrote the login script to the domain. It specifically maps drives as temporary, and re-maps them on login. –  Jeff Dec 30 '09 at 15:49
add comment

It's nothing to do with the domain being Windows 2003. Up until very recently, we've had this exact set up without any problems.

Have you tried enabling userenv logging? You will probably find the answer to your question in the log file.

Note that the KB article isn't for windows 7, however it still applies.

share|improve this answer
    
I did try this. It produces a huge log. But I didn't see any errors or anything indicating any problems. –  Jeff Dec 30 '09 at 15:53
add comment

You didn't mention whether the drive was a magnetic HD or an SSD. I had the same problem with my SSD. It was a JMicron controlled model which after a few months became awfully slow at writing data. How do I know that was the issue? As soon as I put my Velociraptors back in, the problem went away.

share|improve this answer
add comment

netsh interface tcp set global autotuninglevel=disabled

Disable the autotunning feature (win vista/win 7) and you'll bullet speed guaranteed

share|improve this answer
1  
Could you provide an explanation of why disabling TCP autotuning would help here? –  squillman Nov 26 '13 at 14:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.