Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am baffled by the new Task Scheduler in Windows server 2008. I have an application I wrote that Performs some data related tasks. I run this app every 10 mins. If new data is present then it is processed. This app has run for years under Win2k3 server.

I set upi the task in Windows Sever 2008 using the "create basic task" wizard. Most of the menus loook familiar and it looks like there are even more options now. When I get to the end, I open the dialog to tweak the settings and set it to run every 10mins.

The first thing the application does is create a log file, so I wait for the log file to appear. It never does. I launch the application myself by doubld clicking and it appears, so the app is running fine (under the administrator account in which I created the task)

Next I let a day go by and return to examine the "History" tab. According to this, the app has been run every 10 mins for 24 hours or more yet no log file has been created!

Close inspection reveals 6 "events" associated with each occurance: EventID - Task Category - Operational Code

107 - Task triggered on schedule - (1)
319 - Task Engine received message to start - (1)
100 - Task Started - (1)
200 - Action Started - Info
129 - Created Task Process - (2)
201 - Action completed - (2)
102 - Task completed - Info

The Application creates a windows form with which the user can interrupt the processing if need be. On Win23k I would observe it popping up for a second or two and then dissappearing to confirm that the app is being triggered during the day. I do not see the dialog.

To deepen the mystery, the app does actually perform the tasks, meaning it is running.

Can someone explain what is going on here please?

share|improve this question

Sounds like a security\permissions issue related to the creation of the log file to me. Your script isn't breaking so that means that either you're not trapping that error or it is actually creating the log file but the account you're using to look for it doesn't have access although that last possibility seems unlikely.

I think your title is inaccurate- you say that the app does perform the processing tasks so the scheduler is telling the truth and it is executing what you ask it to when required. What's not working is the precise behavior of the script you are running in the security context provided by the scheduler on Win2k8. Have you tried explicitly scheduling it in a particular user context? Simply scheduling a task while logged in as an Administrator will lead to the task being run in System Context which may not do what you expect. There have been changes in this area between W2K3 and W2K8 so it's not surprising (to me at any rate) that something that worked OK on W2K3 would fail on W2K8.

share|improve this answer
Wow that was fast. I am open to suggestions for a better title – Mike Trader Jan 7 '10 at 9:06
Much better title now. :) . Without knowing more about your application I cant be sure but it looks to me that you might be running into a security boundary problem. W2K8 has tightened the controls on some things like having scheduled tasks running in system\service\admin contexts providing interactive interfaces to users as these have been used for privilege escalation attacks in the past. – Helvick Jan 7 '10 at 11:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.