Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We've been moving servers to EC2 lately and I ran into an issue recently involving locales. We use a script to build an AMI from scratch that is largely based on a simplified RightScale script. However, we recently worked on an international project and I discovered that the locale was not set during the scripted install (issuing locale at the command line results in posix). It appear there is no i18n file by default. However, checking a development server that I installed locally (via GUI) the i18n file exists.

What package(s) do I need to install and which program can I run (command line) to configure this during the scripted install?

We're running the current version of CentOS. (5.4)

share|improve this question

2 Answers 2

You can find out what provides using the rpm command. (e.g. rpm -q --whatprovides /full/path/to/your/file )

[root@data ~]# rpm -q --whatprovides /etc/ldap.conf

nss_ldap-253-22.el5_4

Hope this helps... ;-)

share|improve this answer
    
Worked great, but the result said "not owned by any package." :( –  ahanson Dec 22 '09 at 18:49

The "-a" flag on locale will show you all locales for which support is installed. Does that output anything other than posix?

The file /etc/sysconfig/i18n is where the locale gets set for boot time. Here is an example:

# cat i18n
LANG="en_GB"
SYSFONT=Lat2-Terminus16

That is what you would change in the scripted install (I am assuming that your scripted install is not a "Kickstart" type installation. If it is Kickstart then the "lang" directive controls this).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.