Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

php-cgi -v

   PHP 5.2.11-pl1-gentoo (cgi-fcgi) (built: Dec 21 2009 09:10:29)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

System info

dev-lang/php-5.2.11-r1
gentoo 10.1

Update: I' just compiled PHP with the minimal USE flags turned on. Seems better now. Let's wait a bit longer.

share|improve this question
    
Good to know... –  womble Dec 23 '09 at 9:27
    
I'm certainly going to sleep better at night now. –  rodjek Dec 23 '09 at 10:40

2 Answers 2

Well php does this sometimes, you might want to set PHP_FCGI_MAX_REQUESTS environment variable, which will force php to kill itself after some number of requests and being reexecuted, so the problem won't appear.

share|improve this answer
up vote 1 down vote accepted

I' just compiled PHP with the minimal USE flags turned on. No crash again for two days.

BTW: It seems the memory was too small, it was 256MB. Now on a server with 512MB memory, the PHP works well with default USE flags.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.