Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting a error while trying to install rtorrent on my ubuntu server.

./configure --with-xmlrpc-c

I am able to configure it successfully with above command but i get an error when i try to make also when i make install

See the image for error details: http://i50.tinypic.com/11t2wlh.jpg

Being a leaner i don't know what exactly the error is.

share|improve this question
    
What version of xmlrpc-c is installed? –  brent Dec 23 '09 at 14:53

1 Answer 1

up vote 1 down vote accepted

Your xmlrpc-c version is probably out of date. See this ticket: http://libtorrent.rakshasa.no/ticket/1593. Remove libxmlrpc-c3-dev libxmlrpc-c3 and get a copy of xmlrpc-c from SVN and use that. You may need to install svn.

$ cd ~/
$ svn checkout http://xmlrpc-c.svn.sourceforge.net/svnroot/xmlrpc-c/advanced xmlrpc-c
$ cd xmlrpc-c
$ ./configure --disable-cplusplus
$ gmake
$ gmake install
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.