Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to get my tiger clients to bind to an open directory server on leopard.

I am able to bind the computer to the directory and when I look in Workgroup Manager the computer shows up correctly but none of the settings show up on the client. If I attempt to unbind the client from Directory Access on the client it removes but the client pops up a message that it "Could not contact the LDAP server to unbind. Would you like to forcibly remove this configuration?".

I am able to get leopard clients to bind successfully and pull down their settings (OD servers themselves are pulling login window changes).

If (while bound) I use dscl and attempt to cd into the OD I receive a message that the path is invalid.

share|improve this question

When I ran into this problem a couple of weeks ago, the Tiger computer was bound to the Leopard directory server by IP address, and, as you said, when I cded into the appropriate LDAP subfolder using dscl, I got an error message -- most likely an invalid directory. I forcibly unbound and rebound the computer using a DNS name instead of an IP. [Why this makes any sense is beyond me.] I could then cd into the directory using dscl, but the computer was still not allowing network users to log in.

I found the answer to that problem in this thread

Basically, I needed to edit /etc/hostconfig and change



share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.