Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I inadvertantly got .py files stuck to opening my editor instead of running.

share|improve this question
1  
Does serverfault.com/questions/4284/… help at all? –  Chealion May 19 '09 at 5:15
add comment

2 Answers 2

up vote 2 down vote accepted

The reset part is detailed in this article:

  1. Click Start Menu, and then type regedit in the Start Search and press ENTER.
  2. Navigate to the following registry branch HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\[ext].
    Replace the [ext] with the actual file extension that you want to restore its file type association to revert back to original Windows Vista default. If you unsure, simply browse through all the sub-key under FileExts.
  3. Delete the sub-key named UserChoice.
  4. Exit from Registry Editor.

Windows Vista will now use original file associations that comes built into system for the particular file extensions with “UserChoice” deleted.
However, the trick is not foolproof, especially if the other related system registry keys for the particular extension have been corrupted or broken. In such cases, it may be necessary to fix the file association by restoring its registry settings.

share|improve this answer
add comment

To change a file association:

Go Start -> Default Programs

Choose Associate a file type or protocol with a program

Select your .py extension and click Change program...

Choose the executable you want to run your .py files.

share|improve this answer
    
I wish it were this easy, I tried it, and I can locate and touch the interpreter's exe, but it doesn't re-associate. –  DevelopingChris May 19 '09 at 12:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.