Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just installed VMWARE Server (2.02) on a clean install of Windows 7 64bit Pro (systems code-page was set to Big5) and then tried to import some existing VM's from a previous install (Windows XP, VMWARE Server 2.01, CP=codepage-1252).

The web ui reported an error- invalid vmx file.

After searching on google a possible fix came up which is changing the .codepage to Big5 in the VMX file (it was .codepage=codepage-1252) - however I was still unable to import the VM's.

So, to try and fix the problem I changed the windows systems code-page to codepage-1252... But now the vmware web ui wont start - reporting an invalid code-page MS-950.

I've tried un-installing and re-installing vmware server several times all to no avail!

Anyone have any clues as to where I can look to fix this?

share|improve this question
up vote 0 down vote accepted

OK, so the answer was relatively simple in the end. The clue (to myself) was that I was coming from a background of an XP machine...

1. On Win7 (Vista too?), it looks like the machines locale can apply in different user accounts. I had modified my own account - but not applied the changes to "All" accounts - more specically - the systems account. So, whilst half the system was now codepage-1252 the vmware web service was under big5.

Not sure why, but it really does'nt like that.

Under Windows 7 there is an option (new for me) of applying your codepage to all users/accounts whilst XP used to only have a single "system locale".

Changing that fixed the web service problem nicely.

2. And now, for being unable to load the old VM's. That came down to a code page issue. Once I'd looked at the VMX file using the good old trusty "type" i could see double spaced characters.

Reverting to trusty Notepad++ (a most excellent program by the way), loaded the file up and changed the encoding to ANSI saved it down and then re-imported the VM.

Result... Success! Phew..

And now, I must say, looking back, why on earth did I cause myself so much grief and pain by upgrading (???) from XP to Windows 7? Is it really going to be worth the hassle for the extra 4GB of memory space??

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.