Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to install SOAP on PEAR via the command line on Dreamhost. I've upgraded to the latest version of PEAR (1.9.0) but when I try and install SOAP I get the error:

pear/SOAP requires PEAR Installer (version >= 1.5.4), installed version is 1.5.0

I've tried everything I can think of to upgrade, but can't get it to work. Any ideas?

share|improve this question

migrated from stackoverflow.com Dec 28 '09 at 8:57

This question came from our site for professional and enthusiast programmers.

1  
You say PEAR is at v 1.9.0, but the error says PEAR is at v. 1.5.0. –  Ewan Dec 26 '09 at 18:13
    
Yeah, and therein lies the problem. I try to install 1.9.0 and it tells me that that version or newer is already installed, but when I try and instal SOAP it tells me I'm on 1.5.0. –  dazhall Dec 26 '09 at 19:55

2 Answers 2

You can use pear upgrade to upgrade PEAR itself:

pear upgrade PEAR

or:

pear upgrade-all
share|improve this answer
    
[mario]$ pear upgrade PEAR pear/PEAR is already installed and is newer than detected release version 1.9.0 [...] upgrade failed [mario]$ pear install SOAP WARNING: "pear/HTTP_Request" is deprecated in favor of "pear/H" Did not download optional dependencies: [...], use --alldeps to download automatically pear/SOAP requires PEAR Installer (version >= 1.5.4), installed version is 1.5.0 pear/SOAP can optionally use package "pear/Mail" pear/SOAP can optionally use package "pear/Mail_Mime" pear/SOAP can optionally use package "pear/Net_DIME" No valid packages found install failed –  dazhall Dec 26 '09 at 19:59

Got in touch with Dreamhost and they say it's a problem with their setup:

Ah. Yea. The reason why the version does not match is due to back porting done in the Debian version we're using. I'm not sure if there's a way around that but can create a incident report with our system admin if you'd like. But ultimately, it would be best to install a custom copy of PHP and PEAR in order to install custom modules.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.