Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 3com 4200 switch with a fiber connection to the main server room. The link reports up on both ends, but the 4200 neither sends nor receives data on the connection. The end in the server room is sending, but this switch doesn't report receiving anything.

I know there's nothing wrong with the fiber, because I have another switch at the other end of the building that also uses a fiber connection and is working fine. The fiber comes in for both near the problem switch, and so I was able to try the fiber from the good switch and nothing changes.

This fiber connetion aside, the switch is otherwise working. I don't think the port would be bad, or at least one end would report a bad connection, wouldn't it? As far as I can tell there's nothing wrong with the configuration. Certainly nothing changed since when it last worked.

Any ideas appreciated.


The switch that was working is still working, but I've swapped it to use the fiber coming in for the switch that is down. I've pulled in a completely different switch from another building (same model and basic cofig) to connect the line I just swapped that is known to be good. This includes it's sfp and fiber patch, so I'm now using completely different hardware. The only thing the same is the switch at the other end in the server room, and even there I'm on a different unit and port now; no other hardware remains from the failed connection.

Unfortunately, I still can't make them talk to each other. The symptom are the same, even with a different switch. Both ends report the respective ports are up, but there's no traffic. The server room switch reports packets sent down the wire, but the remote switch does not report receiving them and will not send any of it's own.

share|improve this question

My gut says that you haven't tried all possible combinations of patch cables, SFPs, and switch ports. I would suspect that you've got either a failed SFP or a bad patch cable. Since you've got a working switch you've got "ad hoc" test equipment.

Label and systematically swap SFPs and patch cables (one thing at a time) until you've tried all possible combinations. You should be able to populate a matrix describing possible connection topologies until you find a pattern that pinpoints the cause of failure.

share|improve this answer
Still - makes no sense that the switch reports link.. But havent worked much with 3com switches. :-) – Rune Nilssen Dec 29 '09 at 0:46
I updated my question; ports, sfps, cables, and even the switch itself have all been swapped out but no data goes over the connection. – Joel Coel Dec 29 '09 at 19:03
up vote 0 down vote accepted

Final Solution:

I unplugged the fiber patch going to the run termination at the main switch, plugged it back, and the link came back up. Nothing else changed. Note that the other switch was able to successfully use this wiring before re-setting it. Some kind of ghost in the machine, I guess.

I'm still having issues with a vlan on the switch not working correctly, but that will go with a different question.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.