Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've added a certificate to a IIS website, only the HTTPS part of the site doesn't want to start somehow. I see the error below in the System Event Viewer.

Event Type: Error
Event Source:   W3SVC
Event Category: None
Event ID:   115
Date:       29-12-2009
Time:       15:40:30
User:       N/A
Computer:   DELL
Description:
    The service could not bind instance 4.  The data is the error code. 
    For additional information specific to this message please visit the 
    Microsoft Online Support site located at: 
    http://www.microsoft.com/contentredirect.asp. 
Data:
0000: 34 00 00 00               4...    

Before this, I had another website with HTTPS, but I removed this because I only have one IP-address.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Before removing a certificate from an IIS website, remove the IP-port binding (the SSL Port for the SSL identity of the website) first.

If the certificate is already removed, re-add it by choosing "Assign an existing certificate" from the Server Certificate Wizard.

(I know, this is old school. But it took me too much time too find it out, so I documented it here)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.