Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ok, I've tried in the task manager - it didn't worked. Then I've tried in command line by:

taskkill /im name.exe /F

And it says (it's a translation from polish, so it's not exact):

ERROR: can't end process "name.exe" with PID 6788.
Cause: Access denied.

Anybody encountered this? Any solution other then reboot?


locked by HopelessN00b Dec 5 '14 at 10:18

This question exists because it has historical significance, but it is not considered a good, on-topic question for this site, so please do not use it as evidence that you can ask similar questions here. This question and its answers are frozen and cannot be changed. More info: help center.

closed as off topic by Chris S Jan 28 '12 at 3:50

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

You need to have administrative privileges, i.e. in Vista you will need an elevated token to do this. – divo May 19 '09 at 7:58

First, ensure you are running taskkill as an elevated administrator.

Then try Process Explorer from the Sysinternals Suite:

Finally, if a debugger is attached to the process, you may not be able to kill it and will need to log off the user session that the process is running under or even restart the machine.


For a foolproof solution, just use pskill from Sysinternals (now owned by Microsoft)

Assuming you have the privileges pskill will kill any process. I've had processes that TASKKILL and various other methods wouldn't be able to terminate whereas pskill will. (This was for an installation routine, where I needed to kill the process to replace the executable)


I tried all suggestions here and other places and just this one works for me in a similar case:
Advanced Process Termination:
APT suggests 18 different ways to kill a process and has a user interface.
17th way worked for me.


xKill is a similar app to Kill but it’s more advanced in the sense that it can run in the system tray and has a shortcut to activate kill mode. So if an application is not responding, just press Ctrl – Alt – BackSpace. This will activate the kill mode and clicking on any window will terminate that process. To deactivate the kill mode without killing any app, just press Esc.




Use Win32 api, after having set rights on pid.