Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I try to make my subdomain operable on Centos 5 and Tinydns. I've added :

saved and did:


with no errors. But ping does not show this subdomain. What can I do to make my subdomain working using subdomain and how to diagnoze what is wrong now?

Accorindg to @womble i provide results of "Checking addresses of your computers" from:

  1. Reverse lookups: 12 (not good?).
  2. I get some netstat results
  3. Tinydns-get size is 92 so it's less than 512.
  4. Dnsq on issued on my server ip returns valid answer
  5. Dnsqr does not return answer (it's not good right?)
  6. /var/tinydns/log/main folder is empty so i can not diagnose log file (how to enable it?)
  7. Dnstrace shows:

    0:.:.:start:NS:.:. 0:.:.:start:A:.:my_ip 86400 A my_ip failed; timed out failed; timed out

Hope this help to provide answer.

share|improve this question
up vote 2 down vote accepted

Don't use ping. Query the nameserver in question directly with nslook, dig, dnsq or whatever your favourite tool is.

Also, the "Checking addresses of your computers" part of tells you how to query the tinydns data directly.

Edit: Try see if tinydns is listening on the correct interface, run:

netstat -an | grep ".53 "

Which will show all the processes listening on port 53. There should be an entry for your external interface and not just loopback.

share|improve this answer
i have used dig as you suggested and didn't not receive any answer from tinydns. how to diagnose it? – tomaszs Dec 29 '09 at 22:29
See the second part of Alex's answer. – womble Dec 29 '09 at 22:46
@wombe I've upadated question with results from "Checking addresses of your computers". Hope this will help diagose this problem. I have still no idea what can be wrong – tomaszs Dec 29 '09 at 23:21
Any chance you could give us real IP adresses and hostnames to work with? Are you running tinydns on the loopback interface? If so, you'll only be able to reach tinydns from that host. Either run dnscache on an real network interface and let it talk to tinydns - or move tinydns to a real interface. – Alex Holst Dec 29 '09 at 23:32
@Alex I've sent you real ip and hostname. How to check if tinydns runs on loopback? – tomaszs Dec 31 '09 at 12:43

You can try to talk to the authoritative DNS server itself, rather than going through a resolver:

dig @IP-of-TinyDNS

With DNS, if you think you've done it right, it's generally a matter of waiting - for all the other resolvers (for the DJBdns set of programs, that would be dnscache) to clear, or you can force it ("svc -t /service/dnscache") to clear.

Ping is not the right thing though - 'dnsip', or the older 'dig', above.

share|improve this answer
i've tried to force it and have this: error: svc: warning: unable to chdir to /service/dnscache: file does not exist, and dig does not display any DNS answer at all. How to force it to refresh or to diagnose what is wrong? – tomaszs Dec 29 '09 at 22:28
@Alister Bulman And when i do ps-aux I have only tinydns listed and not dnscache if it matters – tomaszs Dec 29 '09 at 22:31
I've updated question with new data – tomaszs Dec 29 '09 at 23:24

You say you ran make but did you restart your server with svc -t /service/tinydns?

Change the /service/tinydns path to match your setup of course.

share|improve this answer
tinydns doesn't need to be restarted if its data.cdb changes. – András Korn Sep 2 '14 at 22:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.