Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have some old classic asp scripts. They used to work on my 2003/IIS 6 server. But on my Vista/IIS 7 and now Windows 7 Ultimate/IIS 7 server the asp pages don't work.

I did what they said here: Deploying a Classic ASP Server (IIS 7) (Microsoft TechNet).

I enabled those 3 features in IIS 7 but that just went from getting 404 to 500 error.

share|improve this question
    
"I wnt from getting a 404 to a 500 error" -- that means check your code. You've probably got a bug in the asp script. –  Joel Coel Aug 28 '11 at 14:21

6 Answers 6

A question: does a simple asp script run or did you try existing pages with includes?

<% Response.Write "Hello, world!" %>

Since you're getting a 500 server error now, could be a sign that something is wrong with your script. Maybe you forgot to enable the Windows Feature (WWW / Application Development Features) "Server-Side Includes"?


It could be a security issue of the application pool account as well. I found this article: loadUserProfile and IIS7 - understanding temporary directory failures. It could be a similar problem.

share|improve this answer

Here are a couple of links which include how to run classic asp on IIS7.

Tips for Classic ASP developers on IIS7

Running classic ASP on IIS 7

Hope this helps you some.

share|improve this answer
    
Well, I've been through both of those posts and still can't get it working. Alex Thissen's post looks like it covers exactly what I need, but I'm not sure it's written well. I have added an application pool called "asp" then converted a folder to an application like it said... but can't figure out how to make it a "site" and map to the right alias when it's an "application". –  Lucenut Dec 29 '09 at 22:14
    
I don't have access to an IIS7 server at the moment, but on IIS6, a site will have an earth icon, and then you should have your folder icons underneath those. An icon of a cog is an application. ASP applications do not need to be an 'application' per say. Its just folder based since it does not need to be precomplied and run in the asp.net app pool. Go through your IIS manager and review what you have. You may just need to remove the folders and start over from the begining. Good luck! –  Chris Dec 29 '09 at 22:38

If you've followed all the guides in the answers, and there's nothing of use in the application or system log, and you are still stuck, you might want to turn on failed request tracing.

share|improve this answer

Hi Caloy we have the same issue

i got this from: forums.iis.net/t/1167295.aspx

"It is recommended that you install Visual InterDev on a Windows platform it supports (Windows XP and so on). VID is no longer supported by Microsoft, so running it on Windows 7 can be problematic.

http://support.microsoft.com/lifecycle/?p1=3022

Install it and develop on an old versions of Windows, and then deploy your site to IIS 7. That's a better approach, as classic ASP is still supported by new versions of Windows/IIS. "

share|improve this answer

TIP: Before considering installing ASP classic on your IIS 7 server, consider how much effort it will take to convert the site to ASP.NET.

I found this question because I too was having problems getting IIS 7 to properly serve up ASP classic. After configuring a bunch of stuff to show errors, traverse parent directories, etc. I got everything working except for the data access. Just that took about 6 hours of trial and error, I was still stuck, and I got the feeling I was opening up a way to easily hack my server.

So, I decided to bite the bullet and convert my 1 mostly static ASP site to ASP.NET. That took only about 5 hours. It eliminated problems with duplicate connection strings all over the place, made deployment a snap, makes me sleep better at night knowing the server is secure, and best of all - I never have to deal with ASP classic again!

share|improve this answer

I ran into this same issue and it turned out to be a simple change to the application pool. If enable 32-bit applications is set to FALSE then I received a prompt to login to the machine. Setting this value to TRUE fixed the issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.