Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm totally new to EC2 and only familiar with some basic Linux commands. I need to get a new Fedora 8 EC2 instance up to retrieve some data that was on a bad server; I have the data mounted via an EBS volume and I'm trying to FTP to the server now to download them. This is a base install of Fedora 8 using the "LAMP Web Starter (AMI Id: ami-2cb05345)" Instance provided by Amazon.

I have a user account created already, and I installed VSFTPD which is running. However, when I try to connect with FileZilla, I am unable to connect. The old server was using Secure FTP but I did not configure it and don't know what it was using to handle FTP (I googled for "Linux ftp" and found VSFTPD).

I'm primarily a Windows guy so I don't know how to configure this.. can anyone help so I can get these files downloaded??

share|improve this question
add comment

3 Answers

Linux boxes use SSHd for both SSH and sFTP (secure FTP).

Download a copy of WinSCP to your windows computer, and then use your SSH details to log into the remote server and download all your stuff.

FTP IS BAD! -passwords and data are all transmitted in clear text :(

Hope this helps.

share|improve this answer
    
The problem though is we have offshore devs who need to FTP code there, should they be using SCP too? –  Wayne M Dec 30 '09 at 16:36
1  
personally I have everyone using SCP. hehe, even Dreamweaver has been supporting it for a few years now :) Frankly, if your devs are desperate to use a unsecured (and severely out of date) protocol for data transfer, I'd be taking a good long look at their code ;) –  BuildTheRobots Dec 30 '09 at 16:50
add comment

Avoid using ftp if you can. It's an old protocol, not secure and not firewall friendly.

First try using scp or sftp. It's available by default if you have sshd installed. Another option is to create a tarball with the files you need and put it on Amazon S3.

If you really must use ftp for some reason you will have to open a few TCP ports on your ec2 security group for passive mode to work. Using vsftpd for instance you have to set pasv_min_port and pasv_max_port in vsftpd.conf and open the corresponding ports.

share|improve this answer
add comment

Set Filezilla to use active mode.

Preferences/Settings->Connection->FTP->Transfer Mode -> Active

Try this link if you think you were wrong in configuring the server.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.