Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Suse Linux 10.0 with an old version of Subversion (1.4). I would like to upgrade it to the current (1.6.6) but I am having problem trying to understand how to build SVN from source. I mean, what should I pass to the configure script? Is there a simple way to upgrade the current SVN?

thanks for the help.

jessica

share|improve this question

2 Answers 2

Is your old version of SVN also built from source, or is it installed from a RPM ? If the latter, I would remove the old version using "zypper remove" or "rpm -e" before you install the new version.

Building SVN from source is pretty straightforward - these are the commands I ran on SuSE 10.2:

wget http://subversion.tigris.org/downloads/subversion-1.6.6.tar.gz
wget http://subversion.tigris.org/downloads/subversion-deps-1.6.6.tar.gz
tar zxvf subversion-1.6.6.tar.gz
tar zxvf subversion-deps-1.6.6.tar.gz  # Puts dependent files in subversion-1.6.6 tree
cd subversion-1.6.6
./configure --with-ssl # Use with-ssl if you want to access your SVN repo via https
make
sudo make install # Installs to /usr/local/bin by default - use the --prefix option for configure script to change the install location
share|improve this answer
    
It's from source. sounds good... let me try it. Is there any chance that it might break anything? or delete config file or repositories? thanks! –  jessica Dec 30 '09 at 18:05
    
I keep on getting APR related errors. Either it cannot install (make install) on a directory that doesn't finish with /lib or when I do add to the configure script --with-apr=/usr/local/apr --with-apr-util=/usr/local/aprutilx/ make fails with subversion-1.6.6/subversion/libsvn_subr/.libs/libsvn_subr-1.so: undefined reference to `apr_hash_clear' –  jessica Dec 30 '09 at 18:53
    
ok, i give up. i guess the upgrade is not going to happen –  jessica Dec 30 '09 at 20:06
    
Just in case you still feel like trying, the error in your second comment looks like it's due to an out of date version of APR. There should be apr and apr-util subdirectories in your subversion-1.6.6 source tree once you unpack subversion-deps-1.6.6.tar.gz to that directory, containing the correct versions of apr and apr-util required for SVN 1.6.6. Are you sure you unpacked the subversion-deps to the right place ? You shouldn't need to specifiy --with-apr or --with-apr-util at all. –  gareth_bowles Dec 31 '09 at 5:06
    
I definitely did. I still get that error. –  jessica Jan 5 '10 at 19:00

For what it's worth, I've had good luck with http://software.opensuse.org/search

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.