Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have been tasked with setting up asp.net websites on a windows server 2008 which are all in debug mode

When browsing a website on the server and an error occurs, for example the database connection cannot be open I would expect as per normal to receive the Asp.net Server error page with an error dump

Something like - http://www.codeproject.com/KB/books/1861005040/image091.gif

However, what actually happens is I get random characters on the web page. For example: <֟)=����*��2o����v��YK�WuZ,�6[N��f�O��b��@!���u]S��yQ�iN�&e�̋�E���j��1z��x����˼�o�y����U֤˪Mϫ��2d�i�4

This is not the correct or expected behaviour. The event log does however show what has gone wrong.

How do I get the Server Error page to render properly, am I missing something in the servers asp.net setup?

share|improve this question
    
Or am I missing something within the IIS 7 configuration of the websites? –  asn187 Jan 2 '10 at 2:29
    
Can you post the source of the page contents(View->Source in IE) –  Jesse Weigert Jul 2 '10 at 21:53
    
any update on this? I'm having the same issue. –  Recursieve Dec 22 '10 at 12:44
add comment

4 Answers

Do you have a Custom Error page for ASP.NET configured in IIS, either globally, for the site, or the Virtual Directory?

share|improve this answer
    
Yes I do, it redirects to it on the application_error event in the global.asax. But I have disabled that functionality to get the asp.net server error page to show on the server. Thanks for the suggestion but I dont think this is to do with the page error not rendering. –  asn187 Jan 5 '10 at 11:21
add comment

Maybe it's an issue with compression. Try to disable compression (web main page, IIS section) in order to see if the error page renders correctly.

Another guess is that there's something wrong with in the character set setting (.NET Globalization in the ASP.NET section).

share|improve this answer
    
I disabled both compression options within iis7 - no luck there. The .net globalization is as it should be - UK English (en-GB). –  asn187 Jan 5 '10 at 19:04
add comment

Are you seeing the same thing in other browsers? Could be your browser settings perhaps?

share|improve this answer
add comment

I'm having the same problem in IIS 7 with ASP.NET 4, but if I change the App Pool to Classic mode the problem no longer occurs. Try to do this.

I my case this doesn't solve the problem, because my application needs to be in Integrated mode...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.