Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As I updated opensuse 11.1 with update packages from october and november 2009, I couldnt use the command ping. For root it gives Permission denied and for a regular user I get cannot open shared object file: Permission denied.

The other coulprit besides the update could be the instalation of google-chrome (.deb file to .rpm, some symbolic links for libs to make chrome work).

When the system rebooted, X server also became blank. Before the reboot it worked, as did chrome, but the ping command didnt work even before the reboot.

Any ideas? I ran some sort of disk check from a rescue CD, libresolv seems as other libs, root has uid=0 ...

share|improve this question
Please provide output of two commands: strace ping; ls -al /usr/lib/libresolv* (or wherever it is) – kubanczyk Jan 3 '10 at 18:54

Thanks for feedback, but I have fixed the issue with glibc packet update. Seems the lib got corrupted or something.

share|improve this answer
libresolv is part of glibc, and had probably bad permission settings. The glibc upgrade overwrote the libresolv and fixed its permissions as well. – peterh Dec 20 '14 at 16:38

have you checked wether selinux is active or not? perhaps there went something wrong. try to start with selinux=0 on your grub/lilo commandline.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.