Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using Eclipse 3.5.1. There is no option called web-->Dynamic web project. Should I install any plugin for Java EE? If so, please provide me the plugin.

share

locked by HopelessN00b Mar 18 at 16:32

This question exists because it has historical significance, but it is not considered a good, on-topic question for this site, so please do not use it as evidence that you can ask similar questions here. This question and its answers are frozen and cannot be changed. More info: help center.

closed as off-topic by masegaloeh, Jenny D, HopelessN00b Mar 18 at 16:32

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on Server Fault must be about managing information technology systems in a business environment. Home and end-user computing questions may be asked on Super User, and questions about development, testing and development tools may be asked on Stack Overflow." – masegaloeh, Jenny D, HopelessN00b
If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers 4

up vote 6 down vote accepted

In Eclipse, go to Help -> Install new software. The Eclipse update site URL to use with the update manager is:

http://download.eclipse.org/webtools/updates/

Enter the above link and test the connection. It will update Eclipse.

share

You'll probably find the 'getting started guides' here helpful.

You probably will need to download the plug-in. The easiest way to do this would be to:

  1. go to Help -> Install new software.
  2. Pick the Galileo repository
  3. All the way at the bottom there are install options for 'Web, XML, and JaveEE Development

... also this is better suited for SO

share
    
This is the correct answer. You need to install the EE and Java Web Tools Plugin. Also I would have expected this on SO :) –  gideon Jul 16 '12 at 8:19

Go to Help > Install New Software... expand "Work with" input and select "Indigo - http://download.eclipse.org/releases/indigo" or write the same text but changing "indigo" for your version of Eclipse. Then select "Web, XML, Java EE and OSGi Enterprise Development" (or something like that) and press "Next". That's it.

share

I had the same problem but couldn't update the standard Java edition because it couldn't resolve dependencies. I downloaded Eclipse JEE which includes all of Java

http://www.eclipse.org/downloads/moreinfo/compare.php

share

Not the answer you're looking for? Browse other questions tagged or ask your own question.