Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

In my home network, I have three machines - trying to do a lab for mirroring on SQL 2008.

> Machine A can connect to B and C. 
> Machine B can connect to A and C. 

> Machine C cannot connect to A nor B.

By connect - I mean clicking Connect in SSMS (Sql Server Mgt Studio) and entering the machine-name\instance name and using SQL Server Auth with a common user/pass. I have also tried System Admin Tools, ODBC System DSN and it cannot connect.

Firewall is off on all machines. SQL Server Configuration Manager -Network Configuration - on all machines has enabled Named Pipes, Shared Memory, and TCP/IP.

Machine C can access files on a share on A with no problems, and wireless internet working fine.

Sorry, we've been fighting this now for about an hour and a half.

I'm trying to install a Vista Telnet to check ports, but that was taking time.

Thanks for any ideas on how to get Machine C to connect?

New Update: from ODBC tried "SQL Server" instead of "SQL Server 10" and it connected. Microsoft SQL Server ODBC Driver Version 06.00.6001.

Clarification Update: om ODBC tried "SQL Server" instead of "SQL Server 10" and it connected. Microsoft SQL Server ODBC Driver Version 06.00.6001. Still don't under stand why "SQL Server 10" from ODBC won't connect. Still cannot connecst using Sql Server Mgt Studio.

Update: the specific error is as follows... Cannot connect to the "server." Additional Information -> A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (.Net SqlClient Data Provider).

share|improve this question

migrated from superuser.com Jan 4 '10 at 21:26

This question came from our site for computer enthusiasts and power users.

Moving this to SF. Considering that it is a lab and mirroring involved you would have much better assistance. –  BinaryMisfit Jan 4 '10 at 21:26

2 Answers 2

Check the SQL Native Client Configuration on Machine C . Make sure that you have the appropriate client protocol(s) enabled.

  • Start SQL Server Configuration Manager on Machine C
  • Expand SQL Native Clent 10.0 Configuration
  • Click on Client Protocols
  • Verify that your desired protocol(s) are enabled and ordered properly

What is the exact error you're getting?

Here are a couple more suggestions:

  • Check that SQL Browser is running on Machines A and B
  • Check the port that SQL is running on on A and B (default is 1433). I'm guessing this is not the problem but....
share|improve this answer
Thanks for the suggestion; however, please see above: I said that: "SQL Server Configuration Manager -Network Configuration - on all machines has enabled Named Pipes, Shared Memory, and TCP/IP." Question: Do they need to be in any special order? –  Jim Messler Jan 4 '10 at 17:24
Yes, I saw that but I'm talking about the Native Client Configuration and not the SQL Server Network Configuration. They are different. The Server Network Configuration is for the protocols that SQL Server itself uses (incoming connections), the SQL Native Client Configuration is for the configuration of the client components on the box (outgoing connections). The SQL Native Client Configuration is immediately below the Server Network Configuration in Config Manager. –  squillman Jan 4 '10 at 18:18
I checked the Native Client and the settings are identical to the Network Configuration: it is enabled for Shared Memory, TCP/IP, and Named Pipes. The order is slightly different from the Network Configuration. Would that make a difference? –  Jim Messler Jan 4 '10 at 19:00
No, it shouldn't actually. I've edited my answer with a couple more suggestions. –  squillman Jan 4 '10 at 19:35
I do appreciate your help in resolving my problem. Please see my new update above. Just out of curiosity, if B can connect to A, how could the Port 1433 or the Sql Browser be the issue? But anyway, I have confirmed that A and B both use Port 1433. –  Jim Messler Jan 4 '10 at 20:12

Have you tried all these steps?


and this article shows a potential problem even when firewall is off: http://blogs.msdn.com/sql_protocols/ It recommends use of a command called "Portqry".

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.