Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a box running Windows 2003 Server at home. I have configured RRAS so I can VPN to my home network from an outside location. The home-LAN uses the 192.168.2.x IP-address range.

Once I connected say, from my workplace, I could see (using IPCONFIG) that the PPTP adapter got an IP address on the home-LAN, 192.168.2.35 for example, and I could ping and connect to the Windows 2003 server box and ALL the other machines on my home LAN, just like I wanted.

Then, one day when I connected to my home LAN I discovered that I could only connect to the server machine itself. The other machines at home were unreachable. Then I realized that I was no longer getting the correct IP address once I connected. Now the PPTP adapter always gets a 169.x.x.x address. I believe this has got something to do with DHCP, but I did not make any configuration changes that I'm aware of.

I read somewhere that one way of solving this is having the RRAS server assign from a static pool of IP-addresses. Is that the only way, if so, how do I do that?

Basically, I just want to be able to connect to my home-LAN using VPN and be able to communicate with all the machines at home, just as if I was at home.

Any ideas?

share|improve this question

migrated from stackoverflow.com Jan 4 '10 at 22:26

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Well ... nevermind!

I found out how to specify a pool of IP addresses for the server to assign to clients rather than use DHCP. I configured that, still not working ... then I realized that the network on the server was more screwed up than I had known. Basically no external connections were working ... I disabled/enabled the Local Area Network connection on the server and now everything works.

Thanks anyways :-)

share|improve this answer
    
When in doubt, reboot! –  Mark Henderson Jan 4 '10 at 22:44

protected by splattne May 16 '12 at 10:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.