Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to get ffmpeg running on my server so I can use the PHP Video Toolkit successfully. I'm currently setting up my testing platform, which is a 32-bit Ubuntu 8.10 Intrepid Ibex Server.

Obviously, my first attempt was

apt-get install ffmpeg

But this pre-compiled version doesn't have libmp3lame or any AMR encoders/decoders and other codecs compiled in.

So I went down the "compiling from source" route. I grabbed the apt source and tried, got all the build-dep's for it and compiled. After an initial challenge (some constants not defined in the config.h), it still wouldn't build, problems relating to h263 encoding functions...

After much Googling with no solutions I tried compiling from the latest SVN/Git repos. But I just keep hitting errors. I can ./configure with all my options, but obviously certain dependencies need to be available (xvid, x264, libvorbis etc). Frustratingly I can't seem to get them to be recognised when "make-ing" these bleeding-edge revisions.

So my main question is: has anyone got ffmpeg working on Ubuntu? If so, how did you go about it?

I have tried following a number of tutorials. I can't post them all here yet (thanks to link limiting), but don't be surprised if you post a link to a tutorial and I've already given it a go.

I will be needing to replicate/adapt this method on my production server (which is a 64-bit Ubuntu 8.04 Hardy Server) so I can get this working there too!

share|improve this question

3 Answers 3

up vote 1 down vote accepted

I think this post from the Ubuntu Forums might be what you're looking for.

I have used this guide for quite some time and I haven't had any trouble getting ffmpeg up and running.

http://ubuntuforums.org/showpost.php?p=8345112&postcount=636

share|improve this answer
    
Thanks mate! I'm sure I spotted this one before... I'm sure I encountered a problem with it, but it has worked this time! –  Simon Jan 6 '10 at 3:22

The medibuntu repositories have a build of ffmpeg with all the patented codecs. You could use those.

For more information please visit their HowTo page.

share|improve this answer
    
Ok, how do I go about getting those? –  Simon Jan 5 '10 at 16:38
1  
medibuntu: medibuntu.org ... repositories how-to: help.ubuntu.com/community/Medibuntu –  quack quixote Jan 5 '10 at 17:36
    
Thanks Quack, I updated the answer. –  Broam Jan 6 '10 at 15:06

libmp3lame and the other codecs are in separate packages from ffmpeg; if you want to go back to the package install option, here's a partial list of packages you might need. You may need to enable some extra repositories to get them :

aalib            libXpm
                 lirc
faac             lzo
faad2            mencoder
fribidi          mplayer
giflib           mplayer-codecs
lame             mplayer-codecs-extra
libdv            mplayer-fonts
libdvdcss-       mplayerplug
libdvdnav        mplayer-skins
libdvdplay       nas
libdvdread       SDL
libfame          slang
libmad           speex
libmp4v2         x264
libmpcdec        x264-gtk
libXaw           xvidcore

Disclosure - I haven't personally installed ffmpeg on Ubuntu, only Fedora and SuSE.

share|improve this answer
    
Surely I can't just install these packages and then 'apt-get install ffmpeg' and expect them to work together? The configure options specifically mandate that certain options need to be enabled, which by default are not... because licensing issues make the compiled package unredistributable –  Simon Jan 5 '10 at 16:04
1  
When I went through this on Fedora I was able to get it working by installing individual packages as you describe. The packages with license restrictions come from a different repository, so you're effectively accepting a different licensing agreement by downloading from that repo. –  gareth_bowles Jan 5 '10 at 16:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.