Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to run point a domain at my pfsense server and have it run a DNS server which is authorative. So I installed TinyDNS.

Ok, so I setup a rule in pf. The rule is TCP/UDP. Source interface is WAN, source address is *, destination address is [PfSense's public WAN IP], destination port is 53.

Then, I proceeded to setting up TinyDNS. All I did here was enter my domain and such and then I added an A record with [Domain] as my domain and [Seperate WAN Server IP] as the destination IP.

Also, TinyDNS is binding to 127.0.0.1, but I've also tried binding to the router's public IP. (note the Router is the PfSense DNS server) Now, the results of dig

-bash-3.2$ dig DOMAIN.com

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.1 <<>> DOMAIN.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40365
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;DOMAIN.com.           IN      A

;; ANSWER SECTION:
DOMAIN.com.    123     IN      A       ROUTER WAN IP

;; Query time: 0 msec
;; SERVER: 209.59.139.5#53(209.59.139.5)
;; WHEN: Tue Jan  5 19:38:52 2010
;; MSG SIZE  rcvd: 53

Instead of going to the IP I intend, it for whatever reason is going to the (PfSense) router IP. It's very strange cause I do not have an A record setup to point to my router, so how is this happening? Also, when I use the http://afraid.org DNS Auth Trace tool, the PFSense router returns an answer but is not authorative.

What am I doing wrong here?

Edit:

I am getting this (with no lookups happening as far as I'm aware) in my TinyDNS logs

TinyDNS Server logs as of Tue Jan 5 21:15:34 UTC 2010

2010-01-05 21:15:18.525985500                :4010 wlan_str                          xmlrpc.php

(with that entry repeating)

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Ok, The first time I tried binding to my public IP, I didn't have an SOA record. Well, now I have a SOA record and binding to my public IP and it works.. so go figure... I forgot about the SOA record for a while I guess..

share|improve this answer

If you want your DNS server answering requests in more than one interface bind to 127.0.0.1 and make NAT (Port Forwarding) for each one of the interfaces to 127.0.0.1 on port 53 TCP and UDP. This is useful if you want to host domain (2 DNS required at least) and just have one serve.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.